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Preface

About This Document

Purpose of This Guide

The TelStrat Application Line Card Installation and Administration Guide (662-00001-01) 
is for telecom and data network managers and administrators who plan, install, and 
manage corporate telecommunications and data networks. This guide contains the 
following information:
� A detailed description of the TelStrat Application Line Card (TALC)
� Procedures necessary to properly install, configure, and manage the TALC in a 

Nortel Meridian 1, Communication Server 1000 (CS 1000), or Communication 
Server 2100 (CS 2100) PBX

� Necessary configuration for the Nortel Meridian 1, CS 1000, or CS 2100 PBX
� Troubleshooting procedures for addressing possible problems

This guide assumes that you are familiar with the following:
� Basic telecommunications terminology
� Basic networking terminology
� PC terminology and operation (specifically, Microsoft Windows 2008, 2003, XP 

Professional Server Edition)
� Nortel Meridian 1, CS 1000, or CS 2100 PBX terminology, functionality, and 

administration

How to Use This Guide
This guide provides step by step procedures for installing, configuring, and managing 
the TALC as a part of product release 3.6 of the Engage Contact Center Suite system. 
Review this guide before beginning TALC installation and configuration.

When you are ready to begin, follow the steps for planning, installing, and configuring 
your hardware in the order that they appear in this guide. This can help you achieve a 
successful, trouble-free installation.
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Skills You Need

Knowledge of, or experience with, the following PC concepts as appropriate to your 
Engage Contact Center Suite system is helpful when administering the TALC:
� Microsoft Windows
� Software installation
� Network configuration

Nortel Product Knowledge
You should be familiar with the following Nortel products to assist you with using the 
TALC:
� Contact Center Manager (CCM), formerly known as Symposium, Portfolio
� Automatic Call Distribution (ACD)
� Basic administration of a Nortel Meridian 1, CS 1000, or CS 2100 PBX (telephone 

set and XDLC configuration)
� Characteristics and principles of XDLC operation
� PBX data calls

Telecommunications Knowledge
You should be familiar with the following aspects of telecommunications:
� PBX configuration
� PBX maintenance (SDI operation)
� Knowledge of RS-232 signaling

Data Networking Knowledge
You should be familiar with the following aspects of data networking:
� Data link (Layer 2 of the OSI model)

— Ethernet switches
� Network (Layer 3 of the OSI model)

— TCP/IP protocol
— Routing
— Addressing
— Traffic analysis and provisioning
— Configuration

� Voice over IP
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Conventions Used in This Guide

This section describes the symbols and text conventions used in this guide.

Instructions for Selecting Menu Options
To simplify the instructions for selecting menu options, this guide abbreviates the 
selection path. For example, if you must choose Telnet from the Logon Unit menu, 
under the Connect menu, this guide uses the following style:

From the Menu Bar, choose Connect → Logon Unit → Telnet.

PBX Terminology
Throughout this guide, the term “host PBX” refers to any of the following Nortel PBX 
platforms:
� Meridian 1 PBX
� CS 1000
� CS 2100

Related Product Information

This section lists sources for additional information related to the Engage Contact 
Center Suite system.

Engage Record CD-ROM
The Engage Record CD-ROM contains the following:

� Documentation in Portable Document Format (PDF)

Note: Readers can view PDF files with Acrobat Exchange, Acrobat Reader, or any 
other application that supports PDF files.

� TALC firmware
� TALC Configuration Manager software
� Engage Record software
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How to Obtain the Engage Record CD-ROM and Publications
You can order the CD from your TelStrat distributor.

You can also download the publications in PDF format from the TelStrat website at:

www.telstrat.com

For more information, refer to the Engage Contact Center Suite Release Notes (663-
00001-01).
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C h a p t e r  1

Description

Product Introduction

The TelStrat Application Line Card (TALC) is an IPE line card that provides connectivity 
between telephones and the Engage Record server to allow for call recording. Install the 
TALC in the host PBX to provide service for up to 32 telephones.

Physical Features
The single-wide, 16-channel version of the TALC (740-01060-01) provides service for 
up to 16 telephones.

The double-wide, 32-channel version of the TALC (740-01060-02 or 740-01060-03) 
provides service for up to 32 telephones. Both versions emulate a standard digital line 
card (XDLC). 

PBX Hardware Compatibility
The following sections list the TALC’s PBX requirements.

Meridian 1 PBX
The TALC is compatible with the following Meridian 1 PBXs:

� Meridian 1 PBX 11, 11C – Cabinet, 11C – Chassis, 11E, 51C, 61C, 71C, and 81C
The TALC is compatible with the 11(C)-mini with the following limitations:
— The 16-port TALC is supported in slots 1—3 in the main chassis.
— The 16-port TALC is supported in slots 7—10 in the expander chassis.
— The 32-port TALC is supported in slots 1 or 2 in the main chassis, with a 

maximum of one TALC.
— The 32-port TALC is supported in slots 7, 8, or 9 in the expander chassis, with a 

maximum of two TALCs.
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Note: Since the 32-port TALC requires two backplane connections, it cannot be 
assigned to slot 10, because this slot provides only one backplane connection.

� Older Meridian 1 PBXs that are upgraded with IPE modules

Note: NT8D37AA IPE cabinets use split-slot wiring. If you have one of these cabinets, 
your TALCs can only reside in slots 0, 4, 8, or 12 unless you re-wire the slot. To use any 
other slot, rewire part of the IPE backplane using Nortel cable NT8D81AA (A0359946). 

CS 1000
To obtain the TALC requirements for Communication Server 1000 (CS 1000) PBXs, 
contact your TelStrat distributor.

CS 2100
The TALC’s required packages for Communication Server 2100 (CS 2100) PBXs are as 
follows:

� X11 packages 0 and 121 contain all the four required Classes of Service.
— Package Number 0 (Basic Call Processing Package) includes FLXA, VCE, and 

WTA.
— Package Number 121 (Station Camp-on) includes CPTA.

� The following four feature sets of release 25.30 include both packages:
— NTSK11CQ: Meridian 1 PBX 11C General Business Feature Set
— NTSK11DQ: Meridian 1 PBX 11C Enhanced Business Feature Set
— NTSK11EQ: Meridian 1 PBX 11C Enterprise Business Feature Set
— NTSK11FQ: Meridian 1 PBX 11C nas/vns Feature Set

For new CS 2100 PBX installations of the TALC card, the CS 2100 PBX does not accept 
a TelStrat Product Number (PEC code) longer than eight characters. Therefore, you 
must map the IPEPEC table of the TALC PEC codes to the XDLC before provisioning 
the TALC channels. Use the following TALC PEC codes to accomplish the mapping:
� T0106001 (TALC 16-channel)
� T0106002 (TALC 32-channel - Meridian 1 PBX 11)
� T0106003 (TALC 32-channel - IPE)
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The following is an example entry:

IPE vs. Meridian 1 PBX 11
The double-wide TALCs for IPE shelves and Meridian 1 PBX 11 cabinets differ slightly 
to accommodate differing card slot dimensions. Each variation has its own order code, 
as outlined in the following table:

Regardless of order code, the motherboard of the 32-channel TALC is the same circuit 
pack that is used for the 16-channel TALC. This circuit pack conforms to the Common 
Features Specification for IPE line cards. It is shown in the illustration on page 5. The 
faceplates for both the 16-channel and 32-channel versions are shown in the illustration 
on page 6.

PBX Software Compatibility
The TALC is compatible with Meridian 1 PBX software release 17 through 22 when 
using TALC firmware release 1_02_00cb6. In addition, the TALC is compatible with 
Meridian 1 PBX software release 23 or higher, CS 1000 PBX software release 2 or 
higher, and CS 2100 PBX software release MSL12 or higher.

Note: You can use the TALC with Release 15 or higher, but the data port configuration 
is slightly different. Refer to the following table for further details.

WRITE ACCESS ENABLED FOR RESTRICTED DATA
>add T0106001        NT8D02     BASIC     DFAULT  LINES_16
TUPLE TO BE ADDED:
T0106001        NT8D02     BASIC     DFAULT  LINES_16
ENTER Y TO CONFIRM, N TO REJECT OR E TO EDIT.
>y
*** DIAGNOSTIC AND TYPE DATA BOUND IN SUCCESSFULLY. ***
TUPLE ADDED
WRITTEN TO JOURNAL FILE AS JF NUMBER 55

>list 6
IPEPEC CRDCODE HARDWARE DIAGNSTC LINES
--------------------------------------
DR70AA NT8D02 BASIC DFAULT LINES_32
8D09BA NT8D09 BASIC DFAULT LINES_16
5D11AE NT5D11 BASIC DFAULT LINES_16
T0106001 NT8D02 BASIC DFAULT LINES_16 <-16-channel TALC card example
T0106003 NT8D02 BASIC DFAULT LINES_32 <-32-channel TALC card example
BOTTOM

Location Order code

Meridian 1 PBX 11 - Cabinet 740-01060-02

IPE shelf 740-01060-03
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Configure the ports on the TALC as a Meridian Communication Adapter (MCA) or an 
Analog Telephone Adapter (ATA) with the first line able to make and receive data calls. 
To configure data ports as MCA or ATA, make the following settings in LD 11: 

For further details, refer to the section on LD s11 in the Meridian 1 PBX X11 I/O Guide 
(NTP 553-3001-400).

Tandem Digit Display
To perform DN Discovery on a feature key other than feature key 0 of any TALC-
connected telephone, the Meridian 1 PBX housing the TALC must run software Release 
23 or later.

Meridian 1 PBX software Release 23 introduced Tandem Digit Display (TDD) class of 
service. From a TALC perspective, TDD enables administrators to configure DN 
Discovery such that the TALC Extension to Dial can be a feature key other than feature 
key 0. For detailed information on DN Discovery and the TALC Extension to Dial field, 
refer to “TALC System Configuration” on page 55.

Configure each port on the TALC from the host PBX database as if it were a standard 
digital line card (XDLC). An integrated Voice over Internet Protocol (VoIP), 10BaseT 
Ethernet interface sends the voice and signaling traffic to the Engage Record server as 
packets.

Upload TALC firmware through a customer-provided Trivial File Transfer Protocol 
(TFTP) server installed on the administration PC, through a 10BaseT Ethernet 
connection.

Meridian 1 PBX software release Setting

15 - 17 CLS prompt = DTA

18 and higher DTA0 prompt = ATA / MCA
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TALC motherboard

G101387

Slots for 
DSP 4

Slots for 
DSP 3

Slots for 
DSP 2

Slots for 
DSP 1
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TALC faceplates: 16-channel and 32-channel

Note: Although TelStrat discontinued the double-wide, 32-channel TALC in May 2008, 
existing deployments of the 32-channel TALC continue to receive TelStrat’s full support.

TX

RX

COL

TX

Transport

RX

COL

Maintenance LED

Ethernet transmit LED

Ethernet receive LED

Ethernet collision LED

G001t

Transport

TALC TALC
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LED Indicators
The red Maintenance LED on the faceplate indicates the basic health of the TALC, just 
as with all other IPE line cards. Under normal conditions, the Maintenance LED lights 
under firmware control at power up, blinks three times after a successful self-test, 
remains lit until the host PBX enables the TALC, then goes out. If the host PBX disables 
the TALC, the Maintenance LED comes on and stays on.
� If, after the TALC passes its self-test, the Maintenance LED comes back on, ensure 

that the card is enabled (refer to host PBX documentation for the correct 
procedure). If the TALC is enabled and the LED remains on, there is a problem at 
the host PBX. 

� If the LED blinks repeatedly at one-second intervals, reseat the TALC by lifting the 
ejector tabs outward and pulling the card toward yourself. This action breaks the 
connection between the TALC and the host PBX backplane. 
After breaking this connection, reinsert the card completely into its slot and push the 
ejector tabs back to the faceplate, locking the card in place. If the TALC still does 
not complete a successful self-test, it must be replaced.

Three other faceplate LEDs monitor transmit and receive activity and collisions over the 
TALC’s Ethernet interface. The 16- and 32-channel TALC faceplates are shown on page 
6 with the function of each LED labeled.

TelStrat DSP 8 Modules
Add up to four TelStrat DSP 8 modules (740-01062-01) to the TALC to extend your 
system’s voice processing capacity.

Each TelStrat DSP 8 module provides an additional eight channels of packet voice 
recording. The illustration on page 5 shows the locations of digital signal processor 
(DSP) expansion slot pairings on the TALC. For help in determining the number of 
TelStrat DSP 8 modules you need to increase your system’s call-processing capabilities 
to the desired level, refer to “Installing TelStrat DSP 8 Modules” on page 15.

The following illustration shows a TelStrat DSP 8 module that holds two DSP devices. 
You can add up to three TelStrat DSP 8 modules to your TALC to increase the line card’s 
call processing capability by up to 32 channels. For the complete installation procedure, 
refer to “Installing TelStrat DSP 8 Modules” on page 15.
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TelStrat DSP 8 module (740-01062-01)

TALC Multi-I/O Cable-Enhanced
The TALC Multi-I/O Cable–Enhanced (800-00072-03) gives you access to the TALC’s 
call processing capabilities. 

This cable provides the following connections:
� 10BaseT for VoIP access to the corporate Ethernet
� RS-232 for Engage Record administration and maintenance through the serial port
� 10BaseT for maintenance of the host PBX over the host PBX’s internal Ethernet
� TCM for linking to each workstation telephone

The following table describes the TALC Multi-I/O Cable–Enhanced.

ATTENTION

The TALC supports only half-duplex 10BaseT Ethernet 

The connector 
labeled is a

that 
transmits and connects to the

P1 female 25-pair 
connector

all signals I/O panel.

Note: If you are using a double-wide, 32-channel TALC, insert P1 into the socket for 
the first of the two card slots occupied by the TALC.

P2 male RJ-45 
connector

10BaseT 
signaling

CLAN Ethernet
(customer LAN on the network).

P3 female DB-9 
connector

RS-232 
signaling

serial port connection for 
administration and maintenance.

G002
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The length of this cable, from the termination end of P1 to the termination end of any of 
the other plugs, is 2 feet (0.6 meters).

TALC Multi-I/O Cable–Enhanced (800-00072-03)

P4 male RJ-45 
connector

10BaseT 
signaling

ELAN Ethernet
(PBX’s embedded LAN).

P5 male 25-pair 
connector

TCM 
signaling

cross-connect to local telephones.

The connector 
labeled is a

that 
transmits and connects to the

G032t

P4
RJ-45
connector (male)

P5 25-pair 
connector (male)

P3 DB-9 (female)

P2
RJ-45
connector (male)

P1 25-pair connector (female)A

B

C

D

E

To TALC slot on PBX's I/O panel

To customer LAN (CLAN)

To serial port

A

B

C

To embedded LAN (ELAN) on PBXD

To cross-connect system for locally 
connected telephones

E
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Meridian Digital Telephone Hardware Compatibility
The TALC is compatible with the following Meridian digital telephone equipment:

Console Telephone Hardware Compatibility
The TALC is compatible with the M2250 Console telephone. However, the M2250 
Console telephone does not display the following Engage Record feature toggles:
� Call Captured and Call Capture Stopped = ECS toggle
� Recording and Recording Stopped = EREC toggle
� Recording Disabled and Recording Enabled = RDIS toggle

The M2250 Console telephone requires two Terminal Numbers (TNs) for voice and 
signaling connection and up to three TNs to supply additional power to the telephone 
set for the add on modules. Configure these additional TNs as PWR type on the PBX. 
For Engage Record, TALC only supports the two main TNs for the M2250 configuration. 
TelStrat does not currently support M2250 Console telephone Auxiliary Power on the 
16- or 32-channel TALC. You must configure additional TNs on an XDLC located in the 
same PBX. Proper wiring has to be established from the TALC and the XDLC. This 
configuration also preserves TALC ports for recording purposes.

TelStrat recommends that you assign a maximum of three M2250 Console telephones 
to a single TALC. However, if you deploy multiple M2250s across multiple TALCs, 
TelStrat recommends that you distribute them evenly across the TALCs to avoid the 
possibility of a single point of failure.

Models Modules

� M2006i

� M2008D
� M2008HFD
� M2216D
� M2616D
� M2616CTii

� M3110

i. M2006 and M3901 digital telephone sets are not capable of displaying local recording 
messages. There may be a loss of call record information as these telephone sets do 

ii. Nortel has discontinued the M2616CT cordless telephone.

� M3310
� M3820
� M3901i

� M3902iii

� M3903iv

� M3904
� M3905

iii. Engage Record feature keys are functional on the M3902 Phase I digital telephone set. 
However, the labels on the telephone are blank after configuring the feature keys. You 
must manually label the feature key on the M3902. Refer to “Configuring a TALC Port” 
on page 70 for details on configuring Engage Record feature keys.

iv. The M3903 Phase I digital telephone set’s Message Waiting key fails once TALC has 
registered the port as a Phase II digital telephone set. This can occur when mixing 
Phase I and Phase II digital telephones sets.

� add-on modulesv

� key-expansion modules

v. Add-on modules include key based add-on modules (KBAs) and display-based add-on 
modules (DBAs) for M39xx sets.
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Operational Characteristics

The TALC provides a number of unique features that distinguish Engage Record from 
other voice recording products.

These features include:
� port sharing
� packet voice processing
� transparent operation
� Meridian digital telephone equipment compatibility

Packet Voice
All connections to the TALC support G.711 and G.723.1 (6.4 kbps) voice compression 
standards. You can assign different voice compression algorithms to individual ports 
(refer to “TALC Port Configuration” on page 68.) This feature allows you to configure 
different voice quality for different users.

Transparent Operation
The host PBX interacts with the TALC as though it were a standard digital line card 
(XDLC). Aside from enhanced functionality, there is no difference in the operation of a 
telephone connected to a TALC and the operation of a telephone connected to an 
XDLC. Additionally, the TALC can operate in XDLC-only mode, if no Engage Record 
server is present.
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Environmental Requirements

The TALC withstands the following environmental conditions without any performance 
degradation or damage.

Note: In this section, the phrase short term equates to 72 consecutive hours with a 
maximum of 15 days per year. The temperature ratings are for the environment of the 
circuit and not the total system.

Specification Minimum Maximum

Operating temperature

Normal (Ambient) 0°C (32°F) 60°C (140°F)

Operating humidity

Normal 5% (noncondensing) 95% (noncondensing)

Storage

Recommended temperature -40°C (-40°F) 70°C (158°F)

Relative humidity 5% RH (noncondensing) 95% RH (noncondensing)
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Installation

General Safety

This section describes general safety guidelines recommended by TelStrat and tools 
needed for line card installation. Follow these safety guidelines whenever you perform 
installation or maintenance tasks on the TALC.

Required Tools
Installation of the TALC and installation or replacement of TelStrat DSP 8 modules 
requires the specific items listed under Hardware Installation. First-time installation or 
maintenance upgrade require those items listed under Software Installation or Upgrade.

Hardware Installation
� Antistatic ESD wrist strap (recommended)
� Phillips-head screwdriver
� Slot-head screwdriver
� Pen or pencil for noting cable lengths and labeling cables
� Cable tie wraps
� Cable identification labels
� Tape measure

Software Installation or Upgrade
� The Engage Record CD-ROM

CAUTION!
. 

CAUTION
Risk of data loss or equipment damage
Electrostatic discharge (ESD) affects the performance of system 
components, such as TelStrat DSP 8 modules and TALCs. It can seriously 
damage such components and decrease their useful life. Be certain you are 
properly grounded before handling them.
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Installation Overview

To assist you with a successful installation, complete the installation in the following 
order:

1 Install the TALCs into the IPE or Meridian 1 PBX 11 cabinet. Refer to “Installing a 
TALC” on page 16 for further details.

2 Connect a TALC Multi-I/O Cable-Enhanced to each slot of the cabinet containing a 
TALC. Refer to “Connecting the TALC Multi-I/O Cable–Enhanced” on page 17 for 
further details.

3 Initially, install the TALC Configuration Manager software on a laptop computer. 
Refer to “Configuration Manager Software Installation” on page 18 for further 
details.

Note: Installing the TALC Configuration Manager software on a laptop computer 
allows you to initially configure the TALC(s) without relocating the Engage Record 
server to perform the configuration. TelStrat recommends that you also install the 
TALC Configuration Manager software on the Engage Record server for future 
configuration changes.

4 Connect a serial cable from the serial port of the laptop to the TALC Multi-I/O cable.

5 Open and logon to the TALC Configuration Manager application.

6 Log onto the TALC using the Serial Connection.

7 Configure the TALC.

8 Reset the TALC.

9 Connect the TALC Multi-I/O Cable-Enhanced RJ-45 plug labeled “external” to the 
data switch using a CAT 5 cable.

10 Repeat steps 1-9 for each TALC.
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Installing TelStrat DSP 8 Modules

Install TelStrat DSP 8 Modules, shown in the illustration on page 8, in the expansion 
slots on your TALC, shown in the illustration on page 5. Adding TelStrat DSP 8 Modules 
to your TALC increases the number of telephone calls that you can record. To add 
TelStrat DSP 8 Modules to your TALC, you must:
� Determine the number of channels that you want to record.
� Install TelStrat DSP 8 Modules using the procedure on page 16.

Determining How Many TelStrat DSP 8 Modules to Add
You must allow one DSP channel on the TALC for each telephone call that you want to 
record. The TALC comes with sufficient on-board DSP resources to record up to eight 
simultaneous telephone calls. In addition, DSP expansion slots enable you to add as 
many as three TelStrat DSP 8 Modules (740-01062-01) to your TALC.

Each TelStrat DSP 8 module increases the voice processing capabilities of your system 
by eight channels. This means that an Engage Record system can simultaneously 
record up to 16 simultaneous conversations with just one TelStrat DSP 8 module added 
to the TALC, or up to 32 conversations with three TelStrat DSP 8 modules added to a 
32-channel TALC.

Once you have ordered and received the TelStrat DSP 8 modules from TelStrat Int’l, 
install them according to the procedure found in “Installing TelStrat DSP 8 Modules” on 
page 16.

Handling TelStrat DSP 8 Modules
Before beginning the installation and configuration process, review “General Safety” on 
page 13. Follow these safety precautions and warnings to protect your investment in 
your telecommunications network.

CAUTION!
. 

CAUTION
Risk of data loss or equipment damage
Electrostatic discharge (ESD) affects the performance of system 
components, such as TelStrat DSP 8 Modules and TALCs. It can seriously 
damage such components and decrease their useful life. Be certain you are 
properly grounded before handling them.
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Installing TelStrat DSP 8 Modules
To install TelStrat DSP 8 Modules:

1 Ground yourself with an approved wrist or heel strap (contact your TelStrat 
distributor for details) before handling TelStrat DSP 8 Modules or TALCs.

2 Clear a flat, static-free work area with sufficient space to hold your TALC and 
TelStrat DSP 8 modules.

3 With the TelStrat DSP 8 modules still in their antistatic bags, place them in the work 
area.

4 Remove the TALC from the host PBX and place it in the work area.

5 Remove a TelStrat DSP 8 module from its antistatic bag, holding it by its edges, with 
the insertion tabs facing down.

6 Insert the tabs into a pair of expansion slots on the TALC. (Refer to the illustration 
on page 5 for the locations of expansion slots.) The tabs should snap into place 
when fully inserted. Visually inspect each tab to make sure that there is no gap 
between the module and the top of the expansion slot, thus ensuring that the 
module is fully inserted.

Installing a TALC

Whether your system consists of one or multiple TALCs, the installation process is the 
same for each one, as follows:

1 Insert the TALC into its card slot.

Ensure that the lower tips of the ejector tabs are positioned properly inside the front 
edges of the shelf.

2 Lock the TALC into position by pushing the handles toward one another until they 
touch the faceplate.

If you meet with inappropriate resistance, stop and reposition the card.

Refer to “LED Indicators” on page 7 for the sequence of LED activity that signifies a 
successful TALC installation. 

3 Verify that the host PBX recognizes the presence of the TALC. (Refer to the 
documentation specific to your host PBX for exact procedures to verify the 
presence of an XDLC.)
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Connecting the TALC Multi-I/O Cable–Enhanced
To connect the TALC Multi-I/O Cable–Enhanced:

Note: Refer to the illustration on page 9 for help identifying the plugs of the TALC Multi-
I/O Cable–Enhanced (800-00072-03).

1 Plug P1 of the TALC Multi-I/O Cable–Enhanced, the 25-pair connector, into the 25-
pair shelf connector associated with the slot occupied by the TALC.

Note: If you are connecting a cable to a double-wide, 32-channel TALC, plug P1 
into the shelf connector associated with the first of the two slots occupied by the 
TALC.

2 Plug P2, the male RJ-45 connector (the first male RJ-45 connector) into your 
Ethernet hub or switch.

Note: The TALC supports only half-duplex 10BaseT Ethernet connections.
3 Plug P3, the female DB-9 connector, into the Engage Record administration PC.

4 Plug P4, the second male RJ-45 connector into the I/O panel connector 
corresponding with the switch’s Input/Output Port (IOP) card.

Note: The TALC supports only half-duplex 10BaseT Ethernet connections.
5 Plug P5, the second 25-pair connector, into the cross-connect device serving the 

local telephones that you want to attach to TALC ports.

Verifying the Installation

Once you have finished the installation and cable connection of your TALC, use the 
information below to verify that you have completed these procedures properly.

Indications of Proper Installation
When a TALC is placed in its slot, it automatically performs a self-test. A successful self-
test indicates proper installation. The following behaviors by the Maintenance LED 
confirm a successful self-test:
� blinking three times
� turning off
� remaining off (if enabled by the switch)

Note: Refer to “LED Indicators” on page 7 for a further explanation of LED behavior at 
startup.
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Indications of Proper Cable Connection
The ability to successfully log on to the TALC through TALC Configuration Manager 
software indicates proper cable connection to the TALC. To perform this task, install the 
software first (refer to page 18). Once this task is complete, refer to “Starting TALC 
Configuration Manager” on page 19.

Unsuccessful Configuration Manager Logon
If you are unable to connect to the TALC Configuration Manager, confirm the TALC 
Multi-I/O Cable–Enhanced connections before attempting the troubleshooting 
procedures.

Note: If the TALC Multi-I/O Cable–Enhanced has proper connections and still does not 
allow you to log on, refer to Chapter 6, “Troubleshooting”.

Configuration Manager Software Installation

Use TALC Configuration Manager software to configure and administer the TALC. This 
software arrives on the Engage Record CD-ROM provided in the package. You must 
install this application on the administration PC to configure and administer the TALC.

To install the TALC Configuration Manager software:

1 Insert the Engage Record CD-ROM in the appropriate drive.

2 Double-click on the Talc → GUIMgmt → Installable → setup.exe.

Result: The InstallShield prepares for installation and then the Welcome screen 
displays.

3 Click on the Next button and follow the screen prompts.

After you install the software on the administration PC, start TALC Configuration 
Manager and choose Configuration Wizard from the Menu Bar. The Configuration 
Wizard allows you to perform initial configuration quickly and easily.
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Using the Configuration Wizard to Perform Initial 
Configuration

The Configuration Wizard option in TALC Configuration Manager allows you to 
configure the minimum information needed for establishing communications between 
the TALC and the Engage Record server. The Configuration Wizard provides only a 
subset of the full configuration settings available in Configuration Manager. However, by 
using the Configuration Wizard, the TALC can be up and running within ten minutes.

You can use the Configuration Wizard in offline mode or while connected and logged on 
to the TALC (online mode).

To perform the initial configuration using Configuration Wizard, you must establish a 
serial connection (online mode). Refer to “Logging on to a TALC Using the Serial Port” 
on page 48. After initial configuration is complete, you can log on to the TALC using a 
Telnet connection. Refer to “Logging on to a TALC Using Telnet” on page 46.

What You Can Configure with the Configuration Wizard
The Configuration Wizard allows you to configure the following elements:
� The TALC’s IP address, subnet mask, and default gateway

This information must be valid for proper functioning with your IP network and to 
successfully establish a Telnet session with the TALC.

� The IP address of the Engage Record server to which the TALC connects

Ensure you have this information ready before you begin.

Note: If, after completing configuration with the Configuration Wizard, you want to 
modify any settings, you must use TALC Configuration Manager.

Starting TALC Configuration Manager
To start TALC Configuration Manager:

1 Click on Start → Programs → TelStrat Engage → TALC Configuration Manager.

Result: Configuration Manager opens and displays the Local User Authentication 
dialog box, similar to the following, prompting you for the login name and password:

2 Enter admin in the Login Name field.
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3 Enter root in the Password field.

4 Click on the OK button.

Result: The TALC Configuration Manager dialog box displays informing you of a 
successful log on.

5 Click on the OK button.

Result: The login status dialog box disappears.

Performing Minimum Configuration with the Configuration Wizard
To perform minimum configuration with the Configuration Wizard (offline or online 
mode):

1 Choose Configuration Wizard from the Menu Bar.

Result: The Configuration Wizard introductory screen displays, similar to the 
following:
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2 After reviewing the message, click on the Next button.

Result: The Configuration Wizard screen displays, similar to the following:

3 Choose your next action from the following table:

IF you want to THEN do the following:

load an existing configuration file into the 
TALC’s Flash memory,

1. Click on the Open File button.
Result: The Open dialog displays, 
similar to the following:

2. Navigate to the location of the 
configuration file that you want to 
load into the TALC’s Flash memory.

3. Select the file.
Result: The name of the selected 
file displays in the file name field. It 
must be a text (.TXT) file.

4. Click on the Open button.
Result: The TALC loads the 
selected configuration file to its 
Flash memory. 

5. Click on the Next button and 
proceed to step 4.

review the information on the previous 
screen,

1. Click on the Back button.
2. Go back to step 2.
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The following is a completed example:

4 Complete the fields on this screen as described in the following table:

create a new configuration file for a TALC, 1. Click on the Next button.
Result: The IP Address screen 
displays, similar to the following 
completed example.

2. Proceed to step 4.

stop the TALC Configuration Wizard, Click on the Close button.
Proceed to page 27 after the table.

view information about the fields on the 
current screen,

Click on the Help button.

Field Description

Set the unique Unit ID 
of the unit

Assign a number between 1 and 254 to the TALC you are 
configuring. 

Note: The unit ID assigned to the TALC must be unique 
from the unit IDs assigned to other TALCs that 
communicate with the same Engage Record server. This 
allows a single Engage Record server to record calls 
from multiple host PBXs simultaneously.

Enter a node name to 
recognize the unit

Enter a name that describes the TALC you are 
configuring.

Enter the Engage 
Record Server IP 
Address

Enter the IP address assigned to the Engage Record 
server.

Note: The Engage Record server’s IP address must be 
statically configured. The Engage Record server cannot 
be configured to obtain an IP address using Dynamic 
Host Control Protocol (DHCP).

IF you want to THEN do the following:

IP information allows you to 
administer the TALC from any PC 
on the network where a copy of the 
TALC Configuration Manager 
software resides.
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5 Click on the Next button.

Result: The Configuration Wizard DN Discovery information window displays, 
similar to the following completed example:

6 Complete the fields on the Configuration Wizard DN Discovery screen as described 
in the following table:

Enter the Local IP 
Address of the unit

Enter the IP address assigned to the TALC you are 
configuring.

Note: If you do not have a valid IP address, enter the 
sample IP address: 5.6.7.8.

Enter the Local IP 
Mask of the unit

Enter the subnet mask of the TALC you are configuring.

Note: If you do not have a valid subnet mask, enter the 
sample subnet mask: 255.255.0.0.

Enter the Local IP 
Gateway of the unit

Enter the IP address of the gateway between the TALC 
you are configuring and the network.

Note: If there is no router between the TALC and the 
network, then the administration PC acts as the gateway. 
Enter 1.2.3.5.

Field Description

Frequency Select how often you want the TALC to automatically 
detect the host PBX-configured name and number 
assigned to each of its ports.
� Choose “Once a Day” if you want the TALC to perform 

DN Discovery daily.
� Choose “Once a Week” if you want the TALC to 

perform DN Discovery weekly.
� Choose “Once a Month” if you want the TALC to 

perform DN Discovery monthly.

Field Description



24 TelStrat Application Line Card Installation and Administration Guide

Installation  Standard 3.6

Time Set the time of day when you want the TALC to perform 
DN Discovery in the time scroll box. Do one of the 
following:
� Highlight the hour displayed in the Time selection box. 

Enter the hour that you want the TALC to perform DN 
Discovery.
Highlight the minute displayed in the Time selection 
box. Enter the minute that you want the TALC to 
perform DN Discovery.

� Highlight the hour displayed in the Time selection box. 
Using the arrows at the right side of the Time field, 
select the hour that you want the TALC to perform DN 
Discovery.
Highlight the minute displayed in the Time selection 
box. Using the arrows at the right side of the Time 
field, select the minute that you want the TALC to 
perform DN Discovery.

Day If you select Once a week, you must also choose the day 
of the week when you want the TALC to perform DN 
Discovery.
In the Day list box, choose the correct day of the week.

Date If you select Once a month, you must also select the date 
when you want the TALC to perform DN Discovery each 
month.
In the Date scroll box, choose the correct date.

Port Choose the TALC port occupied by the DN in the DN field 
that follows. Engage Record uses this port as a baseline 
in deriving DN Discovery information.

Feature Key Choose the feature key assigned to the TALC port and 
DN shown in the adjacent fields. 

DN Enter the directory number of the TALC port where calls 
are to be placed for DN Discovery.

Field Description
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7 Click on the Next button.

Result: A screen similar to the following displays:

8 Do one of the following:

IF you are performing an THEN 

offline configuration, 1. Click on the Save to File button
Result: The Save As dialog box 
displays, similar to the following:

2. Specify the directory path and file 
name for this configuration.
Note: The file name is 
automatically defaulted with the 
name you entered as the node 
name.

3. Ensure the Save as type box 
shows Text File (*.TXT).

4. Click on the Save button.
Result: The previous 
Configuration Wizard screen re-
displays.
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offline configuration,
(continued)

5. Click on the Close button to accept 
the configuration file you just 
created.
Result: A dialog box similar to the 
following displays:

Do the following:

Note: You can open the information in 
this file in Configuration Manager, then 
send and save the file in the TALC’s 
Flash memory at another time.

online configuration, 1. Click on the Save to Flash button.
Result: Configuration Manager 
writes the information entered to the 
Flash memory of the TALC you are 
configuring.

If successful, the following message 
displays: Data Sent Successfully

Note: TelStrat recommends that you 
also save the configuration to a file. 
For instructions on how to do this, 
refer to “offline configuration,” on 
page 25.

2. Restart the TALC.

IF you are performing an THEN 

IF you want to: THEN:

configure more 
TALCs,

1. Click on the Yes 
button.

2. Proceed to step 
3.

stop configuring 
TALCs,

Click on the No 
button.
Result: TALC 
Configuration 
Manager closes.
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Now that you have configured the minimum information required for network 
connectivity, you can do the following tasks:
� Test the network connections. For instructions, refer to "Testing the Connections" 

below.
� Perform additional configuration, if needed. For instructions, refer to Chapter 4, 

“Configuration”.

Testing the Connections

Test the connections to the TALC using the following methods:
1. Check your system’s host-site connections to ensure basic IP Network connectivity.

2. Perform a ping test. To do this test, the TALC must be physically connected to the 
IP network.

Check Ethernet Connections
Check the following points in your Ethernet connection:

1 Confirm that the DB15–RJ45 adapter at Plug 2 of the TALC Multi-I/O Cable–
Enhanced is properly and securely joined to Plug 2.

2 Confirm that the RJ45 plug of a CAT5 data cable leading to your Ethernet hub is 
properly and securely seated in the RJ45 socket of the DB15–RJ45 adapter 
discussed in the previous step.

3 Confirm that the other end of the CAT5 data cable discussed in the previous step is 
properly and securely seated in the appropriate Ethernet hub socket.

4 Confirm that the CAT5 data cable leading to your Ethernet network’s data router is 
properly and securely seated in the appropriate Ethernet hub socket.

5 Confirm that the CAT5 data cable leading from your Ethernet hub is properly and 
securely seated in the data router’s socket.

ATTENTION

The TALC supports only half-duplex 10BaseT Ethernet 
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Performing a TALC Configuration Manager PING
To perform a TALC Configuration Manager PING:

1 From the menu, choose Tests › Ping.

Result: The PING Test dialog box displays, similar to the following:

2 Enter the IP Address of the unit you want to ping.

3 In the Number of Cycles box, enter the number of times you want to ping the unit.

The number must be in the range of 1 to 100.

4 Click on the OK button.

Result: The PING test results screen appears showing the ping results. The 
following is an example of a successful ping.

5 Click on the Close button.

Result: The PING test screen closes.

Unsuccessful Ping
If the ping was unsuccessful:

1 Ensure you have entered the IP address, subnet mask, and default gateway 
correctly.

2 PING the gateway to see if it responds.

3 Contact your data network administrator if the ping still does not work.
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What’s Next?

Once you have confirmed that the TALC can be recognized on the network, you can 
begin to configure it. TelStrat recommends that you also change the passwords for 
logging on to the TALC Configuration Manager and the TALC.

For a description of Configuration Manager, refer to “What is Configuration Manager?” 
on page 31. To change passwords, refer to “Changing the Administration Password” on 
page 75.
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Using Configuration Manager

What is Configuration Manager?

Configuration Manager is a Windows-based software application that you install on your 
PC. Configuration Manager allows you to configure, administer, and upgrade the TALC. 
These tasks can be performed over either of the following connection types:
� 10BaseT Ethernet
� RS-232 serial

The Engage Record CD-ROM includes TALC Configuration Manager software.

Windows PC Requirements
To use Configuration Manager, the administration PC must:
� be an IBM-compatible PC
� use a Windows 2008, 2003, or XP Professional Server Edition operating system 

with the Microsoft TCP/IP networking component installed
� be equipped with a CD-ROM drive
� be equipped with a 10BaseT Ethernet interface card
� have an available COM port if you wish to use the RS-232 serial port to establish a 

direct serial connection
� be equipped with a pointing device, such as a mouse
� use Microsoft’s IP stack
� have 64 Mbytes of RAM for Microsoft Windows 2008, 2003, and XP Professional 

Server Edition
� have 64 Mbytes of available storage for Microsoft Windows 2008, 2003, and XP 

Professional Server Edition

Note: Configuration Manager does not support any of the Win32 Server versions of 
Microsoft Windows.
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Installing Configuration Manager
To install the Configuration Manager software on your administration PC, refer to 
“Configuration Manager Software Installation” on page 18. 

Updating Configuration Manager

Update Configuration Manager at the following website:

www.telstrat.com

Save the software to the local hard drive on your administration PC.

Starting and Viewing Configuration Manager

The Configuration Manager software application is best viewed when your monitor 
settings are configured as 1024 by 768 pixels using Small Fonts at 96 dpi. If you use 
larger fonts, some fields and buttons might be hidden. You must use the horizontal and 
vertical scroll bars to view the hidden fields or buttons. For instructions on changing your 
display settings, refer to the Windows online help on your PC.

To start and log on to a Configuration Manager session:

1 From the Menu Bar, choose Start → Programs → TALC Configuration Manager → 
TALC Configuration Manager.

Result: Configuration Manager opens and prompts you for the login name and 
password, similar to the following:

2 Enter admin in the Login Name box.

3 Enter root in the Password box.

Note: This is the default password. You can change the password after installation, 
though TelStrat recommends that you do not change the password until your 
Engage Record system is up and running.
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4 Click on the OK button.

Result: The system informs you of a successful logon. In the event of an 
unsuccessful logon, the system informs you of the need to re-enter the information.

5 Click on the OK button.

Result: The logon status dialog box disappears.

System Tree
The left pane of Configuration Manager lists the property sheets you can access. To 
expand the list of all the TALC property sheets, click on the plus (+) sign. (To hide the 
list, click on the minus (-) sign.) With the System Tree expanded, click on a configuration 
to display the associated property sheet in the right pane, similar to the following:

To hide the system tree, choose View → System Tree from the Menu Bar. The screen 
redraws itself showing only the right pane and displaying the selected property sheet. To 
display the system tree again, choose View → System Tree.

Property Sheets
When you click an item in the system tree, the associated property sheet appears in the 
right pane.

System 
tree

Property 
sheet

Command 
buttons
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Command Buttons 
The following buttons appear on every property sheet listed in the first level of the TALC 
Configuration Manager system tree (left pane):
� OK

Click on this button to accept any changes you have made to the displayed property 
sheet. This command stores these values in a temporary file on your PC until you 
are ready to update the TALC’s Flash memory. For more details, refer to “OK” on 
page 37.

� Default
Click on this button to insert default values into every field in the displayed property 
sheet.

� Send
Click on this button to update the buffer of the logged on TALC with the values 
currently on the displayed property sheet. For more details, refer to “Send” on page 
38.

� Retrieve
Click on this button to display the saved configuration value for every field on the 
displayed property sheet from the TALC’s local buffer. The TALC’s local buffer 
contains the last sent data. For more details, refer to “Retrieve” on page 38.

� Help
Click on this button to view online Help for the displayed property sheet.
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Configuration Files Description

This section describes configuration files and the ways that you can work with them.

Configuration Manager: File Operations Diagram
The following diagram shows how configuration information is stored. Refer to “Types of 
Files” on page 36 for a detailed description of each file type and operation.

The diagram on page 35 shows the default location to which Configuration Manager 
saves TALC configuration files on the Administration PC—the My Documents folder. 
You can, however, choose a different folder for storage of configuration files in the dialog 
box. The default location for configuration file storage is always the location of the last 
saved configuration file.

G030t

Download (.txt)

Upload (.txt)

Event .dat
file on PC

File Save As or
Save to File (.txt)

OK

Send, followed by Save to Flash

Retrieve

Backup and restore operations

Configuration operations

Telnet or serial
connection

Administration PC

(TALC logon
session)

File Open (.txt)

Configuration Wizard or
Configuration Manager

TALC
configuration file 1

configuration file 2

configuration file 3

configuration file 4

My Documents
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Types of Files
You can work with three types of files in Configuration Manager. Each file is identified by 
one of the file name extensions described in the following table.

File name File type When it is created and used

� event.dat Log file The log (event.dat) file records all activities (and 
messages associated with those activities) that you 
perform while running Configuration Manager, such as:
� logging on to Configuration Manager
� logging on to a TALC (by serial or Telnet connection)
� logging off of a TALC
� performing configuration changes
� performing firmware upgrades
This file can be very useful when troubleshooting system 
problems. Technical support personnel may ask for this 
file.

� *.txt Text The text (.txt) file is created when you do one of the 
following: 
� click on the Save to File button while running the 

Configuration Wizard.
� click on File → Save As while working in 

Configuration Manager.
� choose Upload/Download → Download Configuration 

to save a TALC’s configuration in a text file on the 
administration PC.

� *.upg Upgrade Use the upgrade (.upg) file when performing firmware 
upgrades. For more details, refer to “Performing 
Firmware Upgrades” on page 92.
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Configuration Manager: File Operations Description
The following table describes each operation shown in the “Configuration Manager: File 
Operations Diagram” on page 35.

Operation Description

OK When you click on the OK button, the following occurs:
� Configuration Manager checks any changes you made for errors 

that, if found, produce an error dialog box.
Make the necessary changes, and then click on the OK button 
again. 

Note: You must click on the OK button after making changes to a 
property sheet. For Configuration Manager to be able to save your 
information, you must first click on the OK button to accept the 
changes. After clicking on the OK button, you can send the changes 
to the logged on TALC’s buffer using a Send or Send All command.

You can now update the Flash memory of the logged on TALC by 
performing an Upload/Download → Save to Flash operation from the 
Menu Bar. For more details, refer to “Send” on page 38.

Note: If you do not click on the OK button on a property sheet before 
displaying another property sheet, you lose all of the changes made 
on the first property sheet. To regain lost changes, you must re-enter 
them.

File → Open When you choose File → Open from the Menu Bar, you can open a 
previously saved configuration file. This is useful for preparing and 
storing configuration files in a central location before they are 
deployed to a TALC in the Engage Record system. 

Note: To open a file, the file type must be text (.txt).

File → Save As When you choose File → Save As from the Menu Bar, Configuration 
Manager saves the TALC’s configuration to a file on your PC. You 
must specify the file name and directory location.
After saving the file, you can open and modify it at a later time.
Notes:
� Configuration Manager saves the file as a text (.txt) file.
� If you close Configuration Manager without choosing File → Save 

As, you lose all of the changes you made.
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Send When you click on the Send button, Configuration Manager sends 
any changes made on the displayed property sheet to the buffer of 
the logged-on TALC. If the send is successful, the following message 
displays:
Data Sent Successfully

(TelStrat recommends that you click on the OK button before clicking 
on the Send button.)

Note: You must choose Upload/Download → Save to Flash from the 
Menu Bar to save the changes to the TALC’s Flash memory. For more 
details, refer to “Save to Flash” on page 39.

Send All When you choose Upload/Download → Send All on any property 
sheet, changes for all property sheets pertaining to the logged-on 
TALC are sent to the buffer on the TALC you are connected to. If the 
send is successful, the following message displays:
Data Sent Successfully

Note: You must choose Upload/Download → Save to Flash from the 
Menu Bar to save the changes to the TALC’s Flash memory. For more 
details, refer to “Save to Flash” on page 39.

Retrieve When you click Retrieve on a property sheet, the configuration stored 
in the buffer of the logged-on TALC (the latest configuration 
information) displays in Configuration Manager.
If the retrieval is successful, the following message displays:
Data Received Successfully

Operation Description
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Save to Flash When you choose Upload/Download → Save to Flash from the Menu 
Bar, the information stored in the logged-on TALC’s buffer is saved to 
Flash memory. This prevents the configuration from being lost if the 
TALC loses power.
While in progress, the following message displays in the status bar at 
the bottom of the screen:
Save to Flash

When the Save to Flash is completed, the Data Stored to Flash dialog 
box displays.
Some changes require a restart of the TALC after saving the changes. 
If a restart is necessary, Configuration Manager prompts you to do so.
Notes:
� You must click on the Send button or choose Upload/Download → 

Send All from the Menu Bar before you choose Upload/Download 
→ Save to Flash. You should perform a Save to Flash as often as 
you think it is necessary to keep your configuration information 
safe.

� Do not ignore error messages in the Save to Flash process. If 
Save to Flash fails, retry uploading and saving to Flash. If the 
problem persists, check the file being uploaded and report the 
problem to TelStrat.

Operation Description
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Upload 
Configuration

When you choose Upload/Download → Upload Configuration from 
the Menu Bar, Configuration Manager uploads the configuration file 
you specify and writes the file to the buffer on the logged-on TALC.
Use this option if you need to restore or replace an entire 
configuration.
You must choose Upload/Download → Save to Flash from the Menu 
Bar to save the changes in the TALC’s Flash memory. If you do not 
perform the Save to Flash and a power loss occurs, you lose changes 
to TALC configuration.
While in progress, the following message displays in the status bar at 
the bottom of the screen.
Save to Flash in Progress

When the Save to Flash is complete, the Data Stored to Flash dialog 
box displays.
Notes:
� To upload a configuration file, the file type must be text (.txt).
� To perform a configuration upload over the IP network, a TFTP 

server application must be running on your PC. TelStrat does not 
support uploads over the serial port.

� Restart the TALC after the Save to Flash operation. For 
instructions on how to restart the TALC, refer to “Performing a 
System Restart or Shutdown” on page 51.

� If the upload fails or aborts, confirm that you are uploading the 
correct file. If the problem persists, contact TelStrat Customer 
Services for assistance.

Download
Configuration

When you choose Upload/Download → Download Configuration from 
the Menu Bar, Configuration Manager saves the configuration stored 
on the logged-on TALC to a file on the PC.
Use this option if you want to create a backup of the TALC’s 
configuration.
Notes:
� The downloaded file is saved as a text file (.txt).
� If you make changes and do not save them, you lose those 

changes.

Operation Description
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Working with Configuration Files

This section explains how to:
� create a configuration file
� open a configuration file in Configuration Manager
� perform a configuration upload
� perform a configuration download

Creating a Configuration File on the PC
To create a configuration file on the PC:

1 Start Configuration Manager.

2 Make the required changes on each property sheet.

3 From the Menu Bar, choose File → Save As.

Result: The Save As dialog box displays.

4 Enter a descriptive name for the file.

The file name should identify the type of configuration it contains.

Example 1: If the file contains a basic configuration that is to be used for TALC, you 
can enter template as the file name.

Example 2: If the file contains a configuration that is unique to a specific TALC, you 
can enter the TALC’s name or number as the file name.

5 Ensure that the Save as type drop down box shows text file (*.txt)

6 Specify the folder where you want to save the file.

7 Click on the OK button.

Result: The file is saved.

ATTENTION

TelStrat strongly recommends that you do not manually 
edit .TXT configuration files. Instead, use the procedures 
referenced in the following sections for viewing and 
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Opening a Configuration File
To open a configuration file:

1 Start Configuration Manager.

2 Log on to the TALC.

3 From the Menu Bar, choose File → Open.

Result: The Open dialog box displays.

4 Ensure the Files of type drop down box shows text files (*.txt).

5 Navigate to the folder containing the file you need.

6 Select the file, and then click on the Open button.

Result: The contents of the configuration file are loaded into Configuration 
Manager. 

7 View the configuration details by clicking each item in the system tree to display the 
associated property sheet.

8 Make changes as necessary, then do the following:

a. Save the file by choosing File → Save from the Menu Bar. If you want to change 
the file name, choose File → Save As from the Menu Bar.

b. Click on the Send button to update the TALC, then choose Upload/Download 
→ Save to Flash from the Menu Bar.

Uploading a Configuration to a TALC
For complete instructions on uploading a configuration to a TALC, refer to “Restoring the 
Configuration” on page 80.

Downloading a Configuration from a TALC
For complete instructions on downloading a configuration from a TALC, refer to 
“Creating a Backup Configuration File” on page 78.
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Logging on to a TALC

If you want to update the Flash memory on the TALC as you make configuration 
changes, or view statistics and logs, you must log on to the TALC. Each TALC has its 
own administration ID and password in addition to the Configuration Manager logon ID 
and password.

You can log on to a specific TALC by using either of the following connection methods:
� Telnet (over the IP network) 
� Serial

Connection Types
If the TALC is connected to the administration PC by an RS-232 cable, you can 
establish a connection through the serial port. Similarly, you can establish a modem 
connection if the TALC or Remote Gateway 9150 unit is connected to a modem.

If Ethernet connectivity has been established between the administration PC and the 
TALC, you can establish an IP connection with Telnet.

Default Logon ID and Password
The default logon ID is guest. You cannot change the logon ID.

The default password is guest123. You can change the password and, therefore, it may 
be different if this is not a first time installation. TelStrat recommends that you do not 
change the password until your Engage Record system is up and running smoothly.

Connection History
Configuration Manager maintains a record of past TALC connections. You can select, 
and then connect to a TALC from the history list that displays in the Connect menu.

Note: Upgrading the Configuration Manager software deletes the connection history list.

Auto Logoff
If the connection remains open with no activity for 15 minutes, then Configuration 
Manager automatically logs off the connection and the Session Timed Out message 
displays. This helps to secure the configuration in the event that you walk away from the 
administration PC while logged on to a TALC.
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Logging on to a TALC Using the Connection History
To log on to a TALC using the connection history:

1 From the Menu Bar, choose Connect → XXX.XXX.XXX.XXX (the IP address of the 
TALC that you want to log on to).

Result: If no one else logged on to the TALC before you, the User Authentication 
for Telnet Mode dialog box displays. It is similar to the following:

2 Enter your logon name in the Login Name field. If you have not yet customized this 
setting, refer to “Default Logon ID and Password” on page 43 for the default logon 
ID. 

3 Enter your password in the Password field. If you have not yet customized this 
setting, refer to “Default Logon ID and Password” on page 43 for the default 
password.

4 Click on the OK button.

Result: Configuration Manager initiates a connection attempt. A message similar to 
the following displays in the User Authentication for Telnet Mode dialog box:

Trying to Connect to XXX.XXX.XXX.XXX

Note: The connection speed can be too fast for this message to be seen in a 
successful logon attempt.
If you do not enter any logon information, after two minutes Configuration Manager 
displays a reminder dialog box similar to the following:

Click on the OK button to return to step 2.
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IF the logon attempt THEN 

fails, a message box similar to the following 
displays:

Complete the following actions:
1. Click on the OK button.
2. Go back to Step 1 on page 44 to try again.

is successful, the User Logged In dialog box displays.
Click on the OK button.
Result: The Startup Information dialog box 
displays. It is similar to the following:
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Logging on to a TALC Using Telnet
To log on to a TALC using Telnet:

Note: If someone else logged on to the TALC before you, you cannot log on. You can 
only log on to a TALC using a Telnet connection after you perform the initial 
configuration (refer to “Using the Configuration Wizard to Perform Initial Configuration” 
on page 19) through a serial connection.

1 From the Menu Bar, choose Connect → Logon Unit → Telnet.

Result: The Telnet Configuration dialog box displays, similar to the following:

2 Enter the IP Address of the TALC that you want to connect to, then click on the OK 
button.

Result: The User Authentication for Telnet Mode dialog box displays, similar to the 
following:

is successful,
(continued)

Messages appear above the progress bar at 
the bottom of the dialog box, similar to the 
following:
� Reading Hardware Information

� Reading DSP Load Data

� Reading Configuration Data 

These messages mean that Configuration 
Manager is obtaining the TALC’s 
configuration information from Flash memory. 
When initialization is complete, the 
Configuration Data Read 
Successfully message appears above 
the progress bar.
Click on the Close button.

IF the logon attempt THEN 
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3 Enter your logon name in the Login Name field. Refer to “Default Logon ID and 
Password” on page 43 for the default logon ID if you have not yet customized this 
setting.

4 Enter your password in the Password field. Refer to “Default Logon ID and 
Password” on page 43 for the default password if you have not yet customized this 
setting.

5 Click on the OK button.

Result: The connection attempt is initiated. The message Trying to Connect 
to <IP address> message might appear. 

IF the logon attempt THEN 

fails, the following message displays:
10060 TELNET CONNECTION FAILED

Go back to step 1.

is successful, the User Logged In dialog box displays.
Click on the OK button.
Result: A Startup Information dialog box 
displays, similar to the following:

Messages appear above the progress bar 
at the bottom of the dialog box, similar to 
the following:
� Reading Hardware Information

� Reading DSP Load Data

� Reading Configuration Data 
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Logging on to a TALC Using the Serial Port
To log on to a TALC using the serial port:

Note: You can use the serial connection to perform the initial configuration (refer to 
“Using the Configuration Wizard to Perform Initial Configuration” on page 19).

1 From the Menu Bar, choose Connect → Logon Unit → Serial.

Result: The Serial Port Configuration dialog box displays, similar to the following:

2 Enter the COM port number that the TALC is connected to, then click on the OK 
button.

Result: The User Authentication for Serial Mode dialog box displays, similar to the 
following:

is successful,
(continued)

These messages mean that Configuration 
Manager is obtaining the TALC’s 
configuration information from Flash 
memory. 
When initialization is complete, the 
Configuration Data Read 
Successfully message appears 
above the progress bar.
Click on the Close button.

IF the logon attempt THEN 
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3 Enter your logon name and password, then click on the OK button.

Result: The connection attempt is initiated. The message Trying to Connect 
via Serial Port <port number> might appear. 

IF the logon attempt THEN 

fails, the following message displays:
SERIAL CONNECTION FAILED

Check the serial port connection and 
ensure it is good. Then, go back to step 1.

is successful, the User Logged In dialog box displays.
Click on the OK button.
Result: The Startup Information dialog 
box displays, similar to the following:

Messages appear above the progress bar 
at the bottom of the dialog box, similar to 
the following:
� Reading Hardware Information

� Reading DSP Load Data

� Reading Configuration Data 

These messages mean that Configuration 
Manager is obtaining the TALC’s 
configuration information from Flash 
memory. 
When initialization is complete, the 
Configuration Data Read 
Successfully message appears 
above the progress bar.
Click on the Close button.
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Logging off of a TALC

When you are finished using Configuration Manager to make configuration changes, or 
to view logs and statistics, log off from the TALC. Logging off secures the TALC’s 
configuration.

To log off of the TALC:

1 From the Menu Bar, choose Connect → Logoff Unit.

Result: The LOG OFF dialog box displays, similar to the following:

2 Click on the Yes button.

Result: The TALC Configuration Manager: User Logged Off dialog box displays, 
similar to the following:

3 Click on the OK button.
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Performing a System Restart or Shutdown

Configuration Manager allows you to perform a controlled system restart or shutdown.

You must perform a system restart each time you change the configuration or upgrade 
the firmware. You can perform a shutdown when you need to power-down the system 
for any reason.

Performing a System Restart
To perform a system restart:

1 From the Menu Bar, choose Connect → System Reset → Restart.

Result: The System Restart dialog box displays, similar to the following:

2 Click on the Yes button.

Result: A progress bar displays, similar to the following:

The following message also displays in the status bar at the bottom of the screen:

Restarting the System

The status continues to show Online. When the system restart is complete, a dialog 
box displays informing you that the system restart was successful, and that you are 
logged off.

3 Click on the OK button.

Result: Configuration Manager prompts you to log back on using the previous 
connection method (Serial or Telnet).
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Performing a System Shutdown

To perform a system shutdown:

1 Choose Connect → System Reset → Shutdown from the Menu Bar.

Result: The System Shutdown dialog box displays, similar to the following:

2 Click on the Yes button.

Result: Configuration Manager disconnects your logon session and the following 
message displays in the status bar at the bottom of the screen:

Shutting Down the System

The status shows Offline.

3 Turn the power on the TALC off.

Note: You must turn the power off before you can power the TALC back up.

ATTENTION

Do not perform this procedure if you do not have 
physical access to the TALC. To recover from the system 
shutdown, you must power off the TALC, then turn it 
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Closing Configuration Manager

When you have completed all of the configuration modifications you want to make, or 
are done viewing display logs and statistics, log off and close the Configuration 
Manager application. This secures the configuration, preventing others from accessing 
it if you walk away from the administration PC while logged on to a TALC. To close 
Configuration Manager:

1 Ensure that you have saved all configuration changes by doing one or more of the 
following:

� From the Menu Bar, choose File → Save As, and then specify the name for the 
configuration file. Configuration Manager saves the file on the administration PC 
hard disk.

� Update the Flash memory of the logged on TALC, by doing one of the following:

� Click on the Send button on any property sheet, then choose Upload/
Download → Save to Flash from the Menu Bar.

� Choose Upload/Download → Save to Flash from the Menu Bar.

� If you have saved the changes to a file, choose Upload/Download → Upload 
Configuration → Save to Flash from the Menu Bar. For instructions, refer to 
“Restoring the Configuration” on page 80.

2 Log off by choosing Connect → Logoff Unit from the Menu Bar.

3 Choose File → Exit from the Menu Bar.

Result: Configuration Manager closes.

CAUTION!
. 

CAUTION
Risk of configuration loss
If you close Configuration Manager without saving the 
changes you made to a file on your PC, or without updating 
the Flash memory of the TALC you were working on, all 
changes are lost. You must reenter any changes you made.
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Configuring a TALC Slot in the Host PBX

For the host PBX to communicate properly with the TALC, it must recognize each TALC 
as an extended digital line card (XDLC). This requires that each card slot occupied by a 
TALC be configured at the host PBX as an XDLC slot.

Note: You can configure a TALC’s slot either before or after inserting the card.

To configure a TALC slot, access the host PBX through your host PBX administration 
terminal. At the host PBX administration terminal, instruct the host PBX to recognize any 
slot that a TALC resides in as an XDLC slot. Refer to your host PBX’s documentation for 
the specific steps necessary to complete this procedure.

TALC System Configuration

Use the TALC System Configuration property sheet to set system-wide parameters on 
the TALC. Configure these settings to determine the following information:
� The identity of the TALC within your voice recording network
� Whether the Engage Record server can record calls on this TALC
� The location of the Engage Record server on the IP network
� The times when the TALC automatically determines the directory number (DN) of 

the first line key associated with each TALC port
� The CCM telephone display format for the DNIS and CLID

For an explanation of each field on the TALC System Configuration property sheet, refer 
to “TALC System Configuration Field Descriptions” on page 61.
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TALC System Configuration property sheet

DN Discovery Schedule
The DN Discovery Schedule section of this property sheet contains fields for entering 
information that the TALC needs to determine the directory numbers (DNs) configured 
on the host PBX for each of its ports. When enabled, DN Discovery periodically gathers 
this information for each feature key on the TALC without your having to enter it 
manually every time DN assignments change.

How DN Discovery Works
To perform DN Discovery, each TALC requires one single-appearance DN on a 
telephone connected to that TALC. The TALC disables the ringer on the designated 
appearance but not on that telephone’s other appearances. 

At the appointed time on the selected day or date, each feature key configured as a line 
key on the digital telephone places a call to the TALC DN identified in the “TALC 
Extension to Dial” area of the TALC Configuration Manager’s “TALC System 
Configuration property sheet,” as shown on page 56.
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For each call, the host PBX produces CLID information that identifies the DN of the 
originating feature key. Placing one call from every feature key on every TALC allows 
every TALC to send DN and associated DNIS information to the Engage Record server 
for each call involving a telephone connected to that TALC. In this way, the Engage 
Record server collects DN and associated DNIS information for every telephone on 
every TALC that routes traffic through that server.

Note: DN Discovery does not function on telephone sets that contain add-on modules. 
This causes Engage Record call records to not contain DN and DNIS information.

DN Discovery in ACD Environments
By default, DN Discovery uses port 0 and feature key 0. This is not acceptable in an 
ACD environment that uses feature key 0 as the in-calls key. DN Discovery accepts 
another feature key with a single-appearance DN assigned, but you must also enable 
the TDD class-of-service on the host PBX. Configuring TDD class-of-service allows 
caller ID information to be returned on all keys.

PBX Class-of-Service
Enable the TDD class-of-service on the host PBX to allow acquisition of DN and DNIS 
information in all scenarios (such as, ACD environments, multiple DNs assigned to a 
single phone, and so on).

Contact Center Manager Display Format
If you want Engage Record call records to contain DNIS and ANI information in Contact 
Center Manager (CCM), formerly known as Symposium, ACD environments, then you 
must configure CCM to display DNIS and ANI information on the telephone. This is 
required because the Engage Record server obtains all call record information (for 
example, DNIS, ANI, Agent ID, and so on) from the TALC. The TALC only receives this 
type of information when it is sent to the TALC by the host PBX to be displayed on the 
telephone.

ATTENTION

You must configure CCM to use the English language in 
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Use the following steps to configure CCM to display DNIS and ANI information on the 
telephone:

1 Access the Contact Center Manager Server (CCMS) or CCM Express using the 
CCM Web application, similar to the following:

2 Click on ccmsc → Phoneset Displays in the left pane to display all supported ACD 
telephones (for example, M2216, M2616, M3904, and M3905.)
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3 Double-click on 1 x 24 and 1 x 18 Telephone Set Type, to configure the telephone 
display, similar to the following:

Attention: The 1 x 24 and 1 x 18 display contains two rows. However, Engage 
Record only requires configuration of the first 2 fields of the first row. The first row 
can contain 24 characters and the second row can contain 18 characters. You can 
configure the CLID number (ANI) or DNIS on either row.
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4 Drag the item(s) that you choose, such as the DNIS or CLID number (ANI), to the 
first row of the display, drop them in the order that you choose, and drag the side of 
the item to the appropriate width, similar to the following figures:

5 Click on the OK button.

6 Configure the TALC using the TALC System Configuration property sheet. Refer to 
“TALC System Configuration Field Descriptions” on page 61 for complete details.
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TALC System Configuration Field Descriptions

Field Description

Unit ID Enter a number from 1 through 254 that distinguishes the 
TALC you are configuring from all other TALCs connected to 
the same Engage Record server. One Engage Record server 
can simultaneously record calls from multiple TALCs spanning 
multiple host PBXs.

Node Name Enter a descriptive name for this TALC.

Engage Record 
Feature

� Click on the Enable option button if you want to enable the 
Engage Record server to record telephone calls made to 
ports on the TALC you are configuring.

� Click on the Disable option button if you do not want to 
enable the Engage Record server to record telephone calls 
made to ports on the TALC you are configuring.

Engage Record 
Server IP Address

Enter the IP address of the Engage Record server that 
records telephone calls from this TALC.

Beep Tone Level Use the slider bar to adjust the audio level (volume) of the 
beep tone relative to the voice path. There are five audio 
levels, each step representing approximately 3db.
The default is halfway between minimum and maximum.

Note: The beep tone level can only be adjusted when you 
enable Engage Record using the TALC Port Configuration 
property sheet. Refer to “TALC Port Configuration” on page 68 
for further details.

Per DN Recording Confirm that the Per DN Recording check box is checked if 
you want to record multiple DNs connected to the same TN 
(phone). If you do not want to record multiple DNs connected 
to the same TN, click on the Per DN Recording check box to 
disable this feature. The default is checked (Enable).

Enable DN 
Discovery

� Click in the Enable DN Discovery check box to enable the 
TALC you are configuring to automatically detect the host 
PBX-configured name and number assigned to every line 
key on each TALC port, that is, to enable the TALC to 
perform DN Discovery.

� Do not click in the Enable DN Discovery check box, or click 
again in the check box to clear it, if you do not want the 
TALC to perform DN Discovery.

Note: If you have enabled Recording, DN Discovery is 
required
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Frequency Click on the option button that identifies how often you want 
the TALC to perform DN discovery:
� once a day
� once a week
� once a month

Start DN Discovery Click on the Start DN Discovery button to initiate an 
unscheduled DN Discovery.

Note: Start DN Discovery is available (not grayed-out) only if 
the configuration in the TALC's Flash memory is the same as 
the configuration at the local site, and if the Enable DN 
Discovery check box is selected.

Time Choose the time when you want the TALC to perform DN 
discovery.

Day Choose the day when you want the TALC to perform DN 
discovery (if you selected Once a week in the Frequency 
field).

Date Choose the date when you want the TALC to perform DN 
discovery (if you selected Once a month in the Frequency 
field).

Field Description
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TALC Extension to 
Dial

These fields allow you to specify one TALC port for DN 
discovery. At the configured time, each port on the TALC 
places a call, one at a time, to the DN in the TALC extension to 
dial field. For each call, the TALC assigns the incoming CLID 
name and number to the calling port.
� Port: Choose the TALC port that you want the other ports 

on this TALC to call for DN Discovery.
� Feature Key: Choose the Feature Key that corresponds 

with the port chosen for DN Discovery in the Port list box.

Notes: 

� If the feature key is not key 0, such as in ACD 
environments, you must configure the following classes 
of service on the associated host PBX port: CLS = TDD. 
CLS is the prompt from the host PBX to define the class-
of-service. Enter TDD to enable the Tandem Digit 
Display feature.

� Engage Record feature keys are not supported on 
DBAs.

� DN: Enter the directory number associated with the port 
chosen for DN Discovery in the Port list box.

Symposium 
Display Format — 
DNIS Row

Enter the row number for displaying the DNIS on the 
telephone display.
Valid options are 1 and 2 where 1 is the top row and 2 is the 
bottom row. The default is 1.

Symposium 
Display Format — 
DNIS Offset

Enter the offset number (number of columns counting from left 
to right) for displaying the DNIS on the telephone display.
Valid options are 1 through 24 for the first row of the telephone 
display. Valid options are 1 through 18 for the second row of 
the telephone display. The default is 1.

Symposium 
Display Format — 
DNIS Length

Enter the length of the DNIS to display on the telephone 
display.
Valid options are 0 through 24 for the first row of the telephone 
display. Valid options are 0 through 18 for the second row of 
the telephone display. The default is 10.

Symposium 
Display Format — 
CLID Row

Enter the row number for displaying the CLID on the 
telephone display.
Valid options are 1 and 2 where 1 is the top row and 2 is the 
bottom row. The default is 1.

Field Description
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Note: Symposium Display Format section refers to the format of the CCM Display.

TALC IP Configuration

Use the TALC IP Configuration property sheet to configure information that gives you 
the ability to configure a TALC over an IP connection. This includes the TALC’s
� IP address
� Subnet mask
� Default gateway

For an explanation of each field on the TALC IP Configuration property sheet, refer to 
“TALC IP Configuration Field Descriptions” on page 66.

Symposium 
Display Format — 
CLID Offset

Enter the offset number (number of columns counting from left 
to right) for displaying the CLID on the telephone display.
Valid options are 1 through 24 for the first row of the telephone 
display. Valid options are 1 through 18 for the second row of 
the telephone display. The default is 11.

Symposium 
Display Format — 
CLID Length

Enter the length of the CLID to display on the telephone 
display.
Valid options are 0 through 24 for the first row of the telephone 
display. Valid options are 0 through 18 for the second row of 
the telephone display. The default is 10.

Field Description



TelStrat Application Line Card Installation and Administration Guide 65

June 2012 Configuration

TALC IP Configuration property sheet

Management
In addition to the IP address, subnet mask, and default gateway mentioned above, the 
TALC also allows you to assign a static IP address and IP mask to the management port 
on the TALC. Once you have assigned this information, you can use the host PBX 
administration PC to log on to and administer the TALC through the host PBXs internal 
network.
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TALC IP Configuration Field Descriptions

Entering the IP information
To enter the IP information:

1 Enter the IP address, mask, and gateway of the TALC into the appropriate fields in 
the first three rows of the TALC IP Configuration property sheet.

2 Click on the OK button.

Field Description

IP Address Enter the IP address of the TALC.

IP Network Mask Enter the network mask of the TALC.

IP Gateway Enter the IP gateway of the TALC.

Management: 
Disable

Click in the Disable check box if you do not want to be able to 
complete the host PBX administration from the TALC.

Management: 
Management IP 
Address

Enter the management IP address of the host PBX.

Management: 
Management IP 
Mask

Enter the management IP mask of the host PBX.

IF you want to THEN do the following:

use your host PBX’s management IP 
connection to complete TALC 
administration,

1. Clear the Disable check box.
2. Enter the IP address and mask of 

the TALC’s second Ethernet port 
into the appropriate boxes in the 
Management section of the TALC IP 
Configuration property sheet.

not use to your host PBX’s management 
IP connection to complete TALC 
administration,

Proceed to step 2.
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3 To update the TALC with the new information, click on the Send button.

Note: If you change the TALC IP Address field on the TALC IP Configuration property 
sheet, calls do not record when you initialize a recording through the Engage Record 
client. This is do to the fact that the Engage Record server does not update the board 
list when the same board ID is used with the new TALC IP address. The Engage Record 
server adds the board ID entry. However, when you initialize a recording, the Engage 
Record server references the previous TALC IP address. Therefore, the Engage Record 
server never receives a CallEnd from the expected TALC IP address and therefore does 
not save the call. The Engage Record client generates a warning message in its 
Message Center pane and the system generates a log indicating that duplicate board 
IDs exist. To resolve this issue, you must restart the TALC card after changing a TALC 
IP address.

IF you are THEN 

logged on to the TALC, the changes are written to a temporary 
file on the administration PC. 

Note: To save changes to the TALC’s 
Flash memory, choose Upload → 
Save to Flash.

not logged on to the TALC, a dialog box displays, similar to the 
following:

Log on to the TALC, then on the click 
Send button again.
Result: The revised IP information is 
written to the TALC’s Flash memory.
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TALC Port Configuration

Use the TALC Port Configuration property sheet to configure the following 
characteristics of the telephones connected to ports on the TALC:
� Whether the Engage Record server can record calls through the ports
� The feature keys that are to have Engage Record functionality
� The compression rate that you want the port to use
� Whether you want the port to react with a Telephone Application Programming 

Interface (TAPI) server
� Whether you want the port to be connected to an M2250 Console telephone

Note: The TALC sends CLID information (up to 18 characters) to the Engage 
Record server for calls handled on the M2250 Console telephone Loop Pickup Keys 
(LPKs) and the Engage Record server determines if the call is to be saved. The 
Engage Record server populates the ANI field in the Engage Record client with 
available Caller ID information to and from the M2250 Console telephone set.

� Whether you have fixed-seating ACD configured on your PBX
� Whether you want all parties on a telephone call to hear a beep tone to let them 

know that the telephone call is being recorded.
� Whether you want telephone users, not attached to a TALC, to conference in to an 

unattended DN on the TALC.

TALC Port Configuration property sheet
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TALC Port Configuration Field Descriptions
Configure the settings in the TALC Port Configuration property sheet according to the 
following table:

Fixed Seating
If your ACD agents can log on to their telephone sets using their Make Set Busy keys, 
your PBX is configured for fixed seating. For Engage Record call records to contain 
ACD Agent ID information in this mode of operation, you must access the TALC Port 
Configuration property sheet. From the TALC Port Configuration property sheet, click on 
the Configure button. Click on the Configure Agent ID check box. Enter the ACD 
agent’s Agent ID in the Enter Agent ID field.

Note: This also allows you to create recording criteria using the ACD Agent ID.

Free Seating
If your ACD agents must log on to their telephone sets by entering their Agent ID, your 
PBX is configured for free seating. Your Engage Record system’s call records can 
contain ANI and DNIS information. You must configure CCM to provide DNIS 
information in the first field of the first line of the telephone display. You must configure 
CCM to provide ANI information in the second field of the first line. Refer to “Contact 
Center Manager Display Format” on page 57 for additional information.

Field Description

Enable Click on the Enable option button if you want the Engage 
Record server to be able to record conversations on the 
associated port.

Disable Click on the Disable option button if you do not want the 
Engage Record server to be able to record conversations on 
the associated port.

Configure Click on the Configure button if you want to configure the 
Engage Record feature keys, the compression rate, TAPI 
support, and M2250 support for the associated port.



70 TelStrat Application Line Card Installation and Administration Guide

Configuration  Standard 3.6

Note: This also allows you to create recording criteria using DNIS and ANI information.

Configuring a TALC Port
To configure a TALC port:

1 Click on the appropriate tab for the port you are configuring, as in 0-15 for a single-
wide TALC, 0-15 or 32-47 for a double-wide TALC.

2 Click on the appropriate option button associated with the port you are configuring 
according to whether you want to Enable or Disable recording.

Note: Enable is the default setting. If you do not want to enable recording on a 
specific port, you must select Disable.

3 Click on the Configure button associated with the port you are configuring to set 
the Engage-related feature keys (Conversation Save, Record, Delete Recording) 
and compression rate for any telephone connected to that port.

Result: The TALC Feature Key Configuration dialog box displays, similar to the 
following:

ATTENTION

Choosing fixed seating or free seating is a PBX 
configuration. If your agents must log in with an Agent 
ID, they work in a free seating environment. This is true 
even if they use the same telephone set every shift or if 
they sit in the same seat every shift. Contact your IT 
administrator for further information about this PBX 
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4 Configure the settings in the TALC Port Configuration options dialog box. Refer to 
“TALC Key Feature Configuration Dialog Box Field Descriptions” on page 71 for 
further details.

5 Click on the Send button to update the TALC with the new information.

TALC Key Feature Configuration Dialog Box Field Descriptions

IF you are THEN 

logged in to the TALC, the changes are written into the TALC’s 
buffer.
To save the pages in the TALC’s Flash 
memory, complete an Upload/
Download → Save to Flash.

not logged on to the TALC, the following dialog box displays:

Do one of the following:
� Log on to the TALC, then click on 

the Send button again.
� Save the changes to a file on your 

administration PC.

Field Description

Key Feature Select the Key Feature that you want to assign.
Valid options are Conversation Save Key, Record Key, Delete 
Recording Key, and Not Configured.

Key Number Select the feature key that you want to assign the Key Feature 
chosen in the list box to the left. The feature key must be un-
configured on the host PBX.
Valid options are NC (not configured) and 0 through 75, 
depending on the Meridian digital telephone model.

Compression Rate Choose the compression rate that you want to be applied to 
recordings made through the associated port.
Valid options are G.711 and G.723.1 (6.4K). The default is 
G.723.1. Refer to the Engage Contact Center Suite System 
Administration Guide (662-00012-01) for further information.
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TAPI Support When you enable Telephone Application Programming 
Interface (TAPI) support, telephones using the selected port 
can react to a TAPI server message stimuli such as Meridian 
Communicator.
� Click on the Enable option button if you want this port to 

react to a TAPI server.
� Click on the Disable option button if you want to prevent 

this port from reacting to a TAPI server.
The default is Disable.
When configured for TAPI support, the TALC allocates DSP 
and bandwidth resources whenever a line key indicator goes 
active and stays active for Multiple Appearance DNs. To 
prevent the over-allocation of these resources during midnight 
routines, either disable LD 35, or configure the TALC as 
Offline during this period.

Note: You must configure CS 2100 ATA sets and CS 2100 
AAB sets for TAPI support for them to function properly.

2250 Support When you enable 2250 support, the selected port can interact 
properly with an M2250 console telephone.
� Click on the Enable option button if you want this port to 

interact properly with an M2250 console telephone.
� Click on the Disable option button if you want to prevent 

this port from interacting properly with an M2250 console 
telephone.

� The default is Disable.

2250 Support: 2250 
Secondary Port No.

If you enable 2250 support, select the M2250's secondary port 
from the drop down list.
Valid options are NC (Not Configured) and 0 through 63.
The default is NC.

Agent ID: Configure 
Agent ID

Click on the Configure Agent ID check box if you have fixed-
seating ACD configured on your host PBX.
Note: Do not configure Agent IDs in free seating 
environments. For further information, refer to page 69.

Enter Agent ID If you click on the Configure Agent ID check box, you must 
enter the Agent ID in this field. This must be the same number 
configured as the User ID on the Engage system and as 
Position ID on the host PBX.

Field Description
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Beep Tone When you enable the Beep Tone feature, all parties on a 
telephone call hear a beep tone to let them know that the 
telephone call is being recorded. The beep tone is on for 425 
milliseconds (ms), +/-75 ms, and then off for the remainder of 
15 seconds, repeating this cycle until the call is terminated.
� Click on the Enable option button if you want to enable the 

beep tone.
� Click on the Disable option button if you do not want to 

enable the beep tone.
The default is Disable.

Note: If the telephone user presses the Delete Recording 
feature key, the beep tone is removed and no longer heard by 
all parties on the call. The Conversation Save and Record 
feature keys become inactive while the Delete Recording key 
feature is active. If the telephone user presses the Delete 
Recording feature key a second time to deactivate the feature, 
the beep tone is added back and all parties on the telephone 
call hear the beep tone again. This allows the telephone user 
to delete a portion of the conversation that did not have the 
beep tone supplied to all parties.

Virtual Phone 
Recording

When you enable the Virtual Phone Recording feature, all 
telephone users that are not attached to a TALC, conference 
to an unattended DN on the TALC. The unattended DNs are 
mapped to feature key 0 on an M3904 digital telephone set 
programmed on the PBX. The TALC assumes this PBX 
configuration on the port and acts as if the M3904 digital 
telephone set is actually attached to the TALC. This allows 
telephone calls presented to the M3904 digital telephone sets 
to be recorded through the Engage system. The TALC auto-
answers all telephone calls presented to these unattended 
M3904 digital telephone sets.
� Click on the Enable option button if you want to enable 

virtual phone recording.
� Click on the Disable option button if you do not want to 

enable virtual phone recording.
The default is Disable.

Note: Virtual Phone recording ports do not offer disconnect 
supervision prompting calls to disconnect after a certain 
amount of time. If an outside un-supervised trunk call is 
connected to the Virtual Phone recording port, then that call 
remains active until the Central Office (CO) tells the host PBX 
that the call has been terminated.

Field Description
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Changing the Administration Password

Two layers of password security protect the TALC's configuration. If you want to secure 
the TALC's configuration so that only those with passwords unique to your TALC can 
make configuration changes, alter the following items:
� Configuration Manager password

This password prevents unauthorized users from performing offline configuration 
changes.

� TALC password
This password prevents unauthorized users from performing online changes of the 
configuration in the TALC's Flash memory.

Note: Ensure that you record the password and store it in a safe and secure place. If 
you forget or lose the password, you must re-enter all configuration information. Contact 
TelStrat Customer Services for assistance.

Changing the Configuration Manager Password
To change the Configuration Manager (local) password:

1 Choose Connect → Change Password → Local from the Menu Bar.

Result: The Change Password - Local dialog box displays, similar to the following:
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2 Complete the fields as described in “Password Dialog Box Field Descriptions” on 
page 77.

3 Click on the OK button.

Changing the TALC’s Password
To change the TALC’s (node) password:

1 Choose Connect → Change Password → Node from the Menu Bar.

Result: The Change Password dialog box displays, similar to the following:

2 Complete the fields as described in “Password Dialog Box Field Descriptions” on 
page 77.

IF the password change THEN 

was successful, a message displays, similar to the following:

Click on the OK button.

was not successful, one of the following messages display:

Click on the OK button, then return to step 2.
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3 Click on the OK button.

Result: Please wait. Updating the password... displays in the Change 
Password - Node dialog box.

4 Choose Upload/Download → Save to Flash from the Menu Bar.

Result: Configuration Manager updates the TALC’s memory with the new 
password.

5 Restart the TALC.

Password Dialog Box Field Descriptions

IF the password change THEN 

was successful, a message displays, similar to the following:

Note: This means the password has been 
written to the TALC’s Flash memory.
Click on the OK button.

was not successful, one of the following messages display:

Click on the OK button, then return to step 1.

Field Description

Old Password Enter the existing password.

New Password Enter the new password.

Retype New 
Password

Enter the new password again.
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Creating a Backup Configuration File

Create a backup copy of the TALC’s configuration by downloading the TALC’s 
configuration from Flash memory to a text file on your administration PC. TelStrat 
recommends that you create a backup of your configuration file whenever you make 
configuration changes or after you perform a firmware upgrade.

Storing Backup Configuration Files
The TALC is an extension of the telecommunications and data network. It is extremely 
important that you keep a backup copy of the TALC’s configuration. If the TALC’s Flash 
memory or configuration becomes corrupted or is lost, you can easily restore it.

Store the configuration file in a safe, secure location, such as on backup tape or other 
media that is stored offsite.

TelStrat recommends that you keep the backup files indefinitely.

Creating the Backup File
To create the backup file:

1 Choose Upload/Download → Download Configuration from the Menu Bar.

Result: The Download Configuration dialog box displays, similar to the following:
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2 Choose the mode you want to use for the file transfer according to the following 
table:

3 Click on the Browse button and navigate to the folder where you want to keep the 
configuration text file. 

4 Enter a name for the file in the File name field.

Note: This configuration file becomes your backup file, so ensure the file name is 
meaningful. The file name’s extension must be .TXT.

5 Select the configuration file, and then click on the Open button.

Result: The chosen file displays in the File Name field.

6 Click on the Download button.

Result: The following message displays in the Log Report window:

Downloading Configuration from board. Please wait....

When the download is complete, the following message displays in the Log Report 
window:

Configuration Data download complete

7 Click on the Close button.

IF you wish to save the 
configuration file to THEN do the following:

the administration PC, Click on the Dump option button.

a different location on the IP 
network,

1. Click on the TFTP option button.
Result: This enables the IP Address fields.

2. Enter the IP address of the PC that you 
want to save the configuration file on.
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Restoring the Configuration

Restore the configuration to the TALC’s Flash memory by uploading a configuration text 
file from a PC on the same network as the TALC. To do this, perform the upload over the 
IP network using the TFTP protocol.

You must have a TFTP server application, such as PumpKIN, running on your 
administration PC. The TFTP server’s base directory must point to the directory that 
contains the configuration file you want to upload. 

Before You Begin
Before you can upload the configuration file to the TALC, you must complete the 
following steps:

1 Start the TFTP server application (e.g. PumpKIN).

2 Ensure that the TFTP base directory points to the location of the configuration file.

Uploading a Configuration File Over the IP Network
To upload a configuration file over the IP network:

1 Choose Upload/Download → Upload Configuration from the Menu Bar.

Result: The Upload Configuration dialog box displays, similar to the following:

2 Enter the IP address of the TFTP server in the IP Address fields.

Note: Since the TFTP server application is running on your administration PC, this 
is the IP address of the administration PC.
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3 Click on the Open button.

Result: The Open dialog box displays, similar to the following:

4 Ensure the Files of type drop down box shows Text File (*.TXT), navigate to the 
folder containing the configuration file, select the configuration file, and click on the 
Open button.

Result: The Upload Configuration dialog box displays with the file you selected in 
the File Name field.

5 Click on the Upload button.

Result: If the file opens successfully, then the upload proceeds. The following 
message displays in the status bar at the bottom of the screen:

Uploading Config to Board

The Log Report window displays status messages relating to the upload, similar to 
the following.

CAUTION!
. 

CAUTION
Risk of incorrect operation due to partial configuration.
Do not interrupt the configuration upload. If you interrupt the 
configuration upload, this results in an incomplete configuration in the 
TALC's database. 
If the configuration upload is interrupted, repeat this procedure 
immediately.
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6 On the Upload Configuration dialog box, click on the Save to Flash button.

Result: The FLASH CONFIG dialog box displays, similar to the following:

7 Click on the Yes button.

Result: The following message displays in the status bar at the bottom of the 
screen:

Saving to Flash in Progress

When the save is complete, the following message displays in the middle of the 
Upload Configuration dialog box:

CONFIGURATION IS UPDATED INTO FLASH...

8 Click on the Close button.

9 Restart the TALC. 

Note: For instructions, refer to “Display Logs” on page 83.

IF the upload was THEN 

successful, The following message displays:
CONFIG UPLOAD SUCCESSFUL... USE 
SAVECFG TO UPDATE FLASH.

Proceed to step step 6.

not successful, the following message displays in the 
middle of the Upload Configuration dialog 
box:
CONFIG UPLOAD FAILED

For further instructions, refer to Chapter 6, 
“Troubleshooting”.
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Display Logs

The TALC system keeps track of its performance through statistical logs that technical 
support personnel can use to locate and fix problems. Each line, or display log, 
represents a separate action completed by the TALC. Configuration Manager gives you 
several ways of working with these logs to provide the information technical support 
needs to keep your voice recording system operating at its peak.

Logs are technical support tools. If you request technical support, you may be asked to 
provide a copy of the logs.

Access these logs through the Alarms/Stats/Logs menu. To view the definitions of the 
logs provided by the Engage system, choose Help → Help Topics → Display Logs → 
Display Log Definitions from the Menu Bar.

Viewing Display Logs
To view the display logs:

1 Choose Alarms/Stats/Logs → Display Logs from the Menu Bar.

Result: The Logs dialog box displays, similar to the following: 

2 Use the scroll bar to browse through the logs to find the information that you are 
interested in.

3 When you finish viewing the log, click on the Close button.
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Saving the Log to a File
If you request technical support, the technician often asks for a copy of the logs. To save 
the log to a file on your administration PC, follow this procedure:

1 Select the text you want to copy and then press Ctrl-C.

2 Open WordPad or Notepad.

3 Press Ctrl-V to paste the text.

4 Save and close the text file.

Resizing Logs

Use the Resize logs command to increase (to as many as 1000) or decrease (to as few 
as one) the number of display logs stored in the TALC’s log queue. When the number of 
display logs in the queue reaches the number of lines configured in this field, new 
display logs overwrite existing display logs on a first in, first out basis. 

Note: Because logs are located on the TALC, they do not occupy disk space on the 
administration PC.

Changing the Size of the Display Logs
To change the number of the Display Logs in the queue:

1 Choose Alarms/Stats/Logs → Resize Logs from the Menu Bar.

Result: Configuration Manager displays the current size of the log queue and gives 
you the option of changing the size of the queue.

Note: The queue size, in this case, is the number of display logs in the queue. The 
default capacity of the queue is 1000 display logs.

2 Enter the maximum number of logs you want the TALC to keep in the queue at any 
one time.

3 Click on the OK button.



TelStrat Application Line Card Installation and Administration Guide 85

June 2012 Administration

Clearing Logs

Use the Clear Logs command to discard logs that are no longer useful.

Clearing the Display Logs
To clear the display logs:

1 Choose Alarms/Stats/Logs → Clear Logs from the Menu Bar.

Result: The CLEAR LOGS dialog box displays, similar to the following:

IF you select THEN 

No, the CLEAR LOGS dialog box closes and 
the logs remain as they are.

Yes, � the TALC deletes its stored display 
logs.

� the LOGS Cleared dialog box displays, 
similar to the following:

Click on the OK button.
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Statistics Screens

All statistics screens provided by the Alarms/Stats/Logs menu, function primarily to help 
you obtain information to provide to technical support personnel, upon request.

Digital Signal Processor (DSP) Statistics Screen
Digital Signal Processor (DSP) Statistics provide information about the TelStrat DSP 8 
modules installed on the logged-on TALC. Use this screen to determine the module 
positions that are populated, what type of DSP each populated position contains, and 
the functionality provided by each module. The DSP Statistics screen is similar to the 
following:

To display the DSP Statistics screen, refer to “Displaying DSP Statistics” on page 87. To 
obtain the definitions for the statistics presented on the DSP Statistics screen, refer to 
“DSP Statistics Field Descriptions” on page 87.
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Displaying DSP Statistics
Choose Alarms/Stats/Logs → DSP Statistics from the Menu Bar to display the DSP 
Statistics screen.

Result: Configuration Manager gathers statistics from the TALC and displays the DSP 
Statistics screen, similar to the following:

DSP Statistics Field Descriptions

IF you want to THEN click

update the statistics with the latest 
information,

on the Refresh button.

close the DSP Statistics screen, on the Close button.

obtain descriptions of the statistics in the 
DSP Statistics screen,

on the Help button.

Statistic Description

Single Digit Device 
ID

Identifies internal sequence number for indexing DSP devices.

Module Number Identifies the module position of the DSP.
Valid values are 0, 1, 2, 3, and 4.

Device Number Identifies the DSP device that processed the call.

In Service Identifies the number of voice channels operating on this DSP 
device.

Total MIPS Identifies the total number of MIPS on the DSP device.

Available Mips Identifies the MIPS currently available on the DSP device.

Total Channels Identifies the DSP device's channel capacity.

Total Voice 
Channels

Identifies the total number of voice channels on the DSP 
device.

Available Voice 
Channels

Identifies the number of voice channels currently available on 
the DSP device.

Total Modem 
Channels

Identifies the total number of channels on the DSP device that 
can transmit modem calls.

Available Modem 
Channels

Identifies the number of channels on the DSP device currently 
available to transmit modem calls.
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Voice Connection Table (VCT) Statistics Screen
Voice Connection Table (VCT) Statistics provide information concerning certain 
properties of the voice connections that are active at the time that you request the 
statistics. Technical support personnel use these statistics for troubleshooting 
purposes.The VCT Statistics screen is similar to the following:

To display the VCT Statistics screen, refer to “Displaying VCT Statistics” on page 89. To 
obtain the definitions for the statistics presented on the VCT Statistics screen, refer to 
“VCT Statistics Field Descriptions” on page 89.

Total Flex Channels Identifies the total number of channels on the DSP device that 
can provide multiple functionalities.

Available Flex 
Channels

Identifies the number of channels on the DSP device currently 
available to provide multiple functionalities.

Total Tones 
Channels

Identifies the total number of channels on the DSP device that 
can transmit tones.

Total Reserved 
Channels

Identifies the total number of special purpose channels on the 
DSP device reserved for internal use.

Name Identifies the name of DSP load running on this DSP device.

Statistic Description
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Displaying VCT Statistics
Choose Alarms/Stats/Logs → VCT from the Menu Bar to display the VCT Statistics 
screen.

Result: Configuration Manager gathers statistics from the RLC and displays the VCT 
Statistics screen.

VCT Statistics Field Descriptions

IF you want to THEN click

update the statistics with the latest 
information,

on the Refresh button.

close the VCT Statistics screen, on the Close button.

obtain descriptions of the statistics in the 
VCT Statistics screen,

on the Help button.

Statistic Description

Connection ID Identifies the serial number of this call through the lifetime of 
the logged on TALC.

TALC Port No Identifies the port the call was processed through at the host 
site.

Start Time Identifies the time and date when the call started.

Duration Identifies how long the call lasted.
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Verifying the Firmware and Software Version

This section describes how to determine the version of firmware and software currently 
installed on your TALC.

Before you perform a firmware or software upgrade, determine what version is currently 
installed. This ensures that you do not replace the installed firmware or software with an 
older version.

Verifying the Software Version
To verify your TALC Configuration Manager software version:

1 Choose Help → About Configuration Manager from the Menu Bar. 

Result: The About TALC Configuration Manager dialog box displays, similar to the 
following:

2 Review the About Configuration Manager dialog box. This identifies the version of 
TALC Configuration Manager software installed in your system.

3 Click on the OK button.
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Verifying the Firmware Version
To verify the firmware version on your TALC:

1 Choose System Information → System Data from the Menu Bar.

2 The System Configuration Details dialog box displays, similar to the following:

3 Review the Unit Version box. This identifies the version of firmware installed on the 
TALC.

4 Click on the Close button.

Determining the Current Firmware and Software Versions
To determine what the current firmware and software versions are, refer to the Engage 
Contact Center Suite Release Notes (663-00001-01).
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Performing Firmware Upgrades

This section describes how to perform a firmware upgrade on your TALC. You perform 
the upgrade over the IP network using the TFTP protocol. 

You must have a TFTP server application running on the administration PC. Ensure that 
the TFTP server’s base directory points to the directory that contains the upgrade files. 

When to Perform a Firmware Upgrade
Perform a firmware upgrade when you determine that you are using out-of-date 
firmware. For instructions on determining if you need to perform an upgrade, refer to 
“Verifying the Firmware and Software Version” on page 90.

About Firmware Upgrades and Configuration Files
Each time you perform a firmware upgrade, the configuration database is also 
converted (if necessary) to a format that is compatible with the new firmware. 
Configuration settings are not affected by the conversion. 
TelStrat recommends that each time you perform a firmware upgrade, your first step 
should be to create a backup copy of the converted configuration file, and store it in a 
safe secure location. 

Before You Begin
It is important to complete the following steps before performing a firmware upgrade:

1 Contact TelStrat or your TelStrat distributor to obtain the firmware upgrade.

2 Extract the upgrade files from the file you received from TelStrat. 

3 Start the TFTP server application.

4 Ensure the TFTP base directory reflects the directory where the firmware upgrade 
file you want to use resides.
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Upgrading TALC Firmware
To upgrade the TALC firmware:

1 Choose Upload/Download → Upload S/W from the Menu Bar.

Result: The Software Upload dialog box displays, similar to the following:

2 Enter the IP address of the TFTP server in the IP Address fields.

Note: Since the TFTP server application is running on your administration PC, this 
is the IP address of the PC.

3 Click on the Browse button.

Result: The Open dialog box displays, similar to the following:

4 Ensure that the Files of type drop down box shows Upgrade Files (*.UPG).

5 Navigate to the folder where the firmware file is located.

6 Select the file, and then click on the Open button.
Example: Select talc-100.upg, and then click on the Open button.
Result: The Software Upload dialog box reappears. The file you selected appears 
in the Uploaded File field.
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7 Click on the Upload button.

Wait until the file uploads completely before entering any other commands. The Log 
Report window displays a confirmation message when the upgrade completes.

8 Restart the TALC.

Performing Software Upgrades

Perform a software upgrade if you determine that you are using out-of-date software. 
For instructions on determining if you need to perform an upgrade, refer to “Verifying the 
Firmware and Software Version” on page 90.

Upgrading Configuration Manager Software
To upgrade Configuration Manager software:

1 Navigate to the directory that contains the upgrade files you extracted.

2 Double-click on the setup.exe file.

3 Follow the prompts on screen.

Result: The InstallShield installs the software, overwriting the previous version.
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Troubleshooting

Before You Begin

The questions listed in this section can help you determine the proper course of action 
for addressing your problem.

Identifying Why a Problem Occurred
Before you begin, ask yourself the questions listed in the following table:

Question
IF you
answered: THEN do the following:

Is this a new installation? yes Perform the troubleshooting in the 
sequence presented in this chapter.

no Answer the next question.

Did the TALC work, then 
suddenly stop working?

yes Answer the next question.

no Perform troubleshooting in the sequence 
presented in this chapter.

Did you modify the 
configuration or change any 
hardware components?

yes Verify that changes were made correctly.
Check the hardware components to 
ensure that they are working correctly.
Perform troubleshooting for the specific 
component where the problem occurred.

no Contact your telecom or data network 
administrator. There may be a problem 
with the network.
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TelStrat Application Line Card LEDs

The primary purpose of TALC LEDs is to give you an indication of the line card’s general 
health. When you reset your TALC, watch the faceplate. The LEDs should behave as 
follows:
� The Maintenance LED should flash three times, then go off after the switch enables 

the TALC. (In normal operation of the TALC, the Maintenance LED should remain 
off.)

� The remaining LEDs flash whenever there is network activity.

What to do if the LEDs do not Display Correctly
The following table describes what to do if the LEDs do not display correctly:

Symptom What to do

The Maintenance LED did not flash 
three times during the power-up cycle.

1 Reset the TALC. Watch the 
Maintenance LED again. About 60 
seconds pass before it flashes.

2 If the Maintenance LED still does not 
flash, contact your distributor. There 
may be a hardware problem.

The Maintenance LED is lit after a 
successful self-test.

1 Confirm that the slot is enabled on the 
host PBX.

2 If other LEDs are not lit or flashing, did 
the Maintenance LED ever light? If not, 
contact your distributor. There may be 
a hardware problem.

3 Ensure that the TALC is properly 
seated in its slot and is properly 
inserted into the backplane.

4 If the TALC is improperly or 
incompletely seated, reseat it.

5 If the Maintenance LED remains lit, 
contact your distributor. There may be 
a hardware problem.

The Maintenance LED is flashing. The power-up self-test failed. Contact your 
distributor. There may be a hardware 
problem.

No LEDs are lit on the TALC. Ensure that the TALC is properly seated in 
its slot. If the TALC is properly seated in its 
slot and no LEDs light, contact your 
distributor. There may be a hardware 
problem.
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The Ethernet COLL LED is lit solid. Network collisions are bound to occur and 
are normal. However, if this LED is lit solid, 
do the following:
� Check the physical network connection.
� Verify that you can ping the TALC. 

(Refer to “Using Configuration Manager 
PING”, on page 104.)

� Check the network configuration (such 
as routing, traffic load, and so on). 
Adjust the network configuration, if 
required.

� There should be no broadcast or 
multicast activity on the telephony LAN 
(TLAN). Interconnect a hub and a 
network analyzer to the TLAN and 
monitor for such activity. Identify the 
source(s) and isolate them from the 
TLAN.

Symptom What to do
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Network Connectivity

This section describes problems that can occur on the network and steps you can take 
to resolve those problems.

Symptom Descriptions
If you are not able to establish or maintain data network connectivity, perform 
troubleshooting as described in the following table:

Symptom What to do

You cannot establish a connection from 
your administration PC to the TALC.

1 Ensure that you entered the IP address 
correctly when trying to establish the 
connection.

2 Ensure that you entered the logon ID 
and password correctly when trying to 
establish the connection.

3 Ensure that the TALC’s IP address, 
network mask, and default gateway are 
correctly configured in the TALC.

4 Ping the TALC.
5 Ping the gateway.
6 If the ping still does not work, contact 

your data network administrator.
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10060 TELNET CONNECTION FAILED 
displays when attempting to connect to 
the TALC.

1 Ensure that you entered the logon ID 
and password correctly when trying to 
establish the connection.

2 Ensure that you entered the IP address 
correctly when trying to establish the 
connection.

3 Ensure that someone is not already 
logged on to the TALC.

4 Verify that the Ethernet cable is 
connected at both ends (TALC and 
network hub).

5 Check the Ethernet cable and ensure 
that it is good.

6 Ensure that the TALC is properly 
seated in its slot.

7 Verify that the IP address, subnet mask 
and gateway are all correct on the 
TALC.

8 Ping the TALC. (Refer to “Using 
Configuration Manager PING” on page 
104.)

9 If the TALC does not respond, ping the 
TALC’s gateway to see if it responds.

10 If the gateway does not respond, ping a 
known good device on the TALC’s 
network.

11 If steps 9 and 10 work, but step 8 did 
not, there may be a gateway 
configuration error. Check the TALC’s 
IP Configuration property sheet.

12 Contact your distributor. There may be 
a hardware problem.

Symptom What to do
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SERIAL CONNECTION FAILED displays 
when attempting to connect to the 
TALC.

1 Ensure that you entered the logon ID 
and password correctly when trying to 
establish the connection.

2 Ensure that someone is not already 
logged on to the TALC.

3 Ensure the TALC is properly seated in 
its slot.

4 Reseat the TALC.
5 Ensure that you specified the correct 

COM port when attempting the 
connection. 

6 Verify that no other applications on the 
administration PC are using the COM 
port.

7 Ensure that the serial cable connection 
is good.

8 Use a breakout box to verify that the 
COM port is active.

9 Contact your distributor. There might 
be a hardware problem.

The TALC does not send or receive 
Ethernet traffic.

1 Ensure that the TALC is seated in its 
slot properly and connected to the 
backplane.

2 Ensure that the Ethernet cable 
between the TALC and the network is 
good.

3 Ensure that the Ethernet cable is 
connected.

4 If the TALC still does not send or 
receive traffic, contact your data 
network administrator.

5 Data network administrator: Ensure 
other network devices are configured 
to allow traffic to and from the TALC.

An attempt to log off from the TALC 
does not work.

It is possible that communication has been 
lost between the administration PC and the 
TALC. 
Close and restart Configuration Manager.

Symptom What to do
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There are many collisions on the 
Ethernet network, as indicated by the 
solid Ethernet COLL LED.

Network collisions are normal. However, if 
this LED is lit solid, do the following:
� Check the physical network connection.
� Verify that you can ping the Engage 

server. (Refer to “Using Configuration 
Manager PING” on page 104.)

� Check the network configuration (such 
as routing, traffic load, and so on). 
Adjust the network configuration, if 
required.

� There should be no broadcast or 
multicast activity on the TLAN. 
Interconnect a hub and a network 
analyzer to the TLAN and monitor for 
such activity. Identify the source(s) and 
isolate them from the TLAN.

The TALC cannot establish a 
connection with the Engage server.

1 Verify security authentication 
configuration and ensure that it 
matches at both ends. (For example, if 
security identifier is used, ensure that 
the inbound and outbound security 
identifiers are correctly configured at 
each end.)

2 Ensure that the unit IDs have been 
correctly configured at each end. An 
incorrect unit ID causes security 
authentication to fail.

3 Ensure that the TALC’s IP address is 
correctly configured on the Engage 
server.

4 Verify that the IP network is operational 
(up and running) as appropriate.

5 Ensure that the TALC is enabled on the 
host PBX.

6 Use the Ping option in Configuration 
Manager to ping the Engage server. 
For instructions, Refer to “Performing a 
Configuration Manager PING”, on page 
104.

7 If the Engage server does not respond, 
check the network configuration (such 
as routing, traffic load, and so on). 
Adjust the network configuration, if 
required.

Symptom What to do
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Software Problems

This section identifies some problems that can occur with the Configuration Manager 
software, and describes what to do to resolve them.

Symptom Descriptions
If you are not able to complete a task with Configuration Manager, perform 
troubleshooting as described in the following table:

Symptom What to do

The Configuration Manager software 
installation fails.

Ensure that you close all background 
applications, including anti-virus software, 
before performing the installation.

When performing one of the following 
by TFTP, ERROR: FILE OPEN FAILED 
displays:
� configuration upload
� Engage firmware upgrade

1 Ensure that the TFTP server 
application is installed and running on 
your administration PC.

2 Ensure that the file you are trying to 
upload is present in the target directory, 
that is, either in the TFTP directory, or 
in the directory that is specified as the 
base directory in the TFTP server 
application.

3 Review messages displayed by the 
TFTP server application for clues.

4 Ping the Engage server to verify that 
network connectivity exists.
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CONFIG UPLOAD FAILED displays when 
attempting to perform a configuration 
upload by TFTP.

1 Ensure that you selected an 
appropriate file. That is, ensure that the 
file you attempted to upload is a TALC 
configuration file.

2 Ensure that the configuration file you 
are attempting to upload is compatible 
with current Engage firmware.

3 Perform the configuration upload using 
a previous configuration file, if 
necessary. 

Note: Each time you perform a Engage 
firmware upgrade, you should also create 
a backup of the configuration. The 
configuration database format in the TALC 
is dependent on the version of firmware 
installed on the TALC. If you recently 
downgraded to a previous version of 
Engage firmware, you may also need to 
revert to a previous configuration format.

System not responding displays 
when working with Configuration 
Manager.

It is possible that communication has been 
lost between the administration PC and the 
TALC. 
Close Configuration Manager, and then 
restart it.

Nothing happens when attempting to 
log off from the TALC.

It is possible that communication has been 
lost between the administration PC and the 
TALC that you were logged on to. 
Close Configuration Manager, and then 
restart it.

Symptom What to do
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Using Configuration Manager PING

This section explains how to use the Ping option provided in Configuration Manager to 
verify connectivity. Use this procedure as a troubleshooting tool to determine if you can 
reach all network TALCs, or any other device on the network.

Performing a Configuration Manager PING
To perform a Configuration Manager PING:

1 From the menu, choose Tests → Ping.

Result: The PING Test dialog box displays, similar to the following:

2 Enter the IP Address of the TALC that you want to ping.

3 In the Number of Cycles box, enter the number of times you want to ping the TALC.

The number must be in the range of 1 to 100.

4 Click on the OK button.

Result: The PING test results dialog box displays, showing the ping results. The 
following is an example of a successful ping.



TelStrat Application Line Card Installation and Administration Guide 105

June 2012 Troubleshooting

The following is an example of an unsuccessful ping.

5 Click on the Close button.

Result: The PING test dialog box closes.

What to do if the Ping Did Not Work
If the ping was unsuccessful, answer these questions:

1 Did you enter the IP address correctly?

2 Are the subnet mask and default gateway configured properly at your site? 
(Confirm this by checking the IP Configuration property sheets for the involved 
TALCs.)

3 Are the subnet mask and default gateway configured properly at the site that you 
are pinging? (Confirm with the site’s network administrator.)

4 Does the gateway respond to a ping?

If you are able to answer “Yes” to the questions above and the ping still does not work, 
the problem lies somewhere in the network between the involved sites.

ATTENTION

It is possible to successfully ping a device (for example, a TALC) on the 
network and still not be able to log on to that device. If you log on to a 
TALC using a serial connection and neglect to log off, you can 
successfully ping the TALC. However, you cannot establish a Telnet 
connection. The TALC only allows one logon at a time.
If you cannot log on to a TALC after a successful ping, ensure that you 
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Responding to a Catastrophic Failure

For the purposes of this discussion, a catastrophic failure is defined as a failure of the 
equipment to operate after review of all troubleshooting information and implementation 
of appropriate procedures.

Inoperative Hardware
Should your TALC fail to operate after thorough review of the troubleshooting 
information in this and related guides, consult your distributor for hardware replacement.
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Pin-out Table for TALC Multi-I/O 
Cable-Enhanced

Reading the Table

The first line of the table below is read as follows:

In pair 1 of bundle W1, the red wire connects pin P1-21 to pin P2-5 and carries the 
following signal: EN0RXD+.

In
pair

of
bundle the

wire 
connects
pin

to
pin

and carries the 
following signal:

1 W1, RED P1-21 P2-5 EN0RXD+.

1 W1, BLK P1-46 P2-12 EN0RXD-.

2 W1, WHT P1-22 P2-6 EN0TXD+.

2 W1, BLK P1-47 P2-13 EN0TXD-.
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TALC Multi-I/O Cable-Enhanced

Introduction
The TALC Multi-I/O Cable–Enhanced (800-00072-03) is a 6-plug cable that provides the 
following connectivity:

The connector at is a providing connectivity to

P1 25-pair the switch’s I/O panel

P2 DB-15 an external (user) Ethernet port

P3 DB-9 a serial port

P4 DB-15 the switch’s internal Ethernet port

P5 (reserved)
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Pin-out Information
The following table shows the pin-out of the TALC Multi-I/O Cable–Enhanced:

In
pair

of
bundle the

wire 
connects
pin

to
pin

and carries the following 
signal:

1 W1, BLK P1-21 P2-5 EN0RXD+.

1 W1, RED P1-46 P2-12 EN0RXD-.

2 W1, BLK P1-22 P2-6 EN0TXD+.

2 W1, WHT P1-47 P2-13 EN0TXD-.

P2-4 GND (SHD).

1 W2, BLK P1-17 P3-3 SDIRXD.

1 W2, RED P1-42 P3-2 SDITXD.

2 W2, BLK P1-45 P3-5 GND.

2 W2, WHT

P3-1 P3-4 SDIDTR-SDIDCD.

P3-4 P3-6 SDIDTR-SDIDSR.

P3-7 P3-8 SDIRTS-SDICTS.

1 W3, BLK P1-23 P4-5 EN1RXD+.

1 W3, RED P1-48 P4-12 EN1RXD-.

2 W3, BLK P1-24 P4-6 EN1TXD+.

2 W3, WHT P1-49 P4-13 EN1TXD-.

1 W4, BLK P1-1 P5-1 (reserved)

1 W4, RED P1-26 P5-26 (reserved)

2 W4, BLK P1-2 P5-2 (reserved)

2 W4, WHT P1-27 P5-27 (reserved)

3 W4, BLK P1-3 P5-3 (reserved)

3 W4, GRN P1-28 P5-28 (reserved)

4 W4, BLK P1-4 P5-4 (reserved)

4 W4, BLU P1-29 P5-29 (reserved)
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5 W4, BLK P1-5 P5-5 (reserved)

5 W4, YEL P1-30 P5-30 (reserved)

6 W4, BLK P1-6 P5-6 (reserved)

6 W4, BRN P1-31 P5-31 (reserved)

7 W4, BLK P1-7 P5-7 (reserved)

7 W4, ORG P1-32 P5-32 (reserved)

8 W4, RED P1-8 P5-8 (reserved)

8 W4, WHT P1-33 P5-33 (reserved)

9 W4, RED P1-9 P5-9 (reserved)

9 W4, GRN P1-34 P5-34 (reserved)

10 W4, RED P1-10 P5-10 (reserved)

10 W4, BLU P1-35 P5-35 (reserved)

11 W4, RED P1-11 P5-11 (reserved)

11 W4, YEL P1-36 P5-36 (reserved)

12 W4, RED P1-12 P5-12 (reserved)

12 W4, BRN P1-37 P5-37 (reserved)

13 W4, RED P1-13 P5-13 (reserved)

13 W4, ORG P1-38 P5-38 (reserved)

14 W4, GRN P1-14 P5-14 (reserved)

14 W4, WHT P1-39 P5-39 (reserved)

15 W4, GRN P1-15 P5-15 (reserved)

15 W4, BLU P1-40 P5-40 (reserved)

16 W4, GRN P1-16 P5-16 (reserved)

16 W4, YEL P1-41 P5-41 (reserved)

1 W5, BLK P5-9 P6-2 (reserved)

1 W5, RED P5-34 P6-14 (reserved)

2 W5, BLK P5-10 P6-3 (reserved)

In
pair

of
bundle the

wire 
connects
pin

to
pin

and carries the following 
signal:
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2 W5, WHT P5-35 P6-16 (reserved)

3 W5, BLK P5-11 P6-4 (reserved)

3 W5, GRN P5-36 P6-5 (reserved)

4 W5, BLK P5-12 P6-20 (reserved)

4 W5, BLU P5-37 P6-6 (reserved)

5 W5, BLK P5-13 P6-8 (reserved)

5 W5, YEL P5-38 P6-7 (reserved)

6 W5, BLK P5-14 P6-17 (reserved)

6 W5, BRN P5-39 P6-9 (reserved)

7 W5, BLK P5-15 P6-24 (reserved)

7 W5, ORG P5-40 P6-11 (reserved)

8 W5, RED P5-16 P6-15 (reserved)

8 W5, WHT P5-41 P6-12 (reserved)

In
pair

of
bundle the

wire 
connects
pin

to
pin

and carries the following 
signal:
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Fields Index

Numerics
2250 Secondary Port No. 72
2250 Support 72

2250 Secondary Port No. 72

A
Agent ID 72

Configure Agent ID 72
Enter Agent ID 72

B
Beep Tone 73
Beep Tone Level 61
Browse

Software Upload 93

C
COM port number 48
Compression Rate 71
Configure 69

D
Date 62
Day 62
Default (button) 34
Disable 66, 69
DN Discovery Schedule

Date 62
Day 62
Enable DN Discovery 61
Frequency 62
Start DN Discovery 62
TALC Extension to Dial 63
Time 62

E
Enable 69
Enable DN Discovery 61
Engage Record Feature 61
Engage Record Server IP Address 61
Enter a node name to recognize the unit 22
Enter Agent ID 72
Enter the Local IP Address of the unit 23
Enter the Local IP Gateway of the unit 23
Enter the Local IP Mask of the unit 23

F
Feature Key Configuration

Key Feature 71
Key Number 71

Files of type 42
Frequency 62

G
General Config

Engage Record Feature 61
Engage Record Server IP Address 61
Node Name 61
Per DN Recording 61
Unit ID 61

H
Help (button) 34

I
IP Address 46

IP Configuration 66
Software Upload 93

IP Gateway 66
IP Network Mask 66
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K
Key Feature 71
Key Number 71

L
Login Name 32, 44, 47

M
Management

Disable 66
Management IP Address 66
Management IP Mask 66

Management IP Address 66
Management IP Mask 66

N
New Password 77
Node Name 61

O
OK (button) 34, 37
Old Password 77
Open

Upload Configuration 81

P
Password 32, 44, 47
Per DN Recording 61

R
Retrieve (button) 34, 38
Retype New Password 77

S
Save as type 41
Send (button) 34, 38
Set the unique Unit ID of the unit 22
Start DN Discovery 62

T
TALC Extension to Dial 63
TALC Feature Key Configuration

2250 Support 72
2250 Secondary Port No. 72

Agent ID
Configure Agent ID 72
Enter Agent ID 72

Beep Tone 73
Compression Rate 71
Feature Key Configuration

Key Feature 71
Key Number 71

TAPI Support 72
Virtual Phone Recording 73

TALC IP Configuration
IP Address 66
IP Gateway 66
IP Network Mask 66

TALC Port Configuration
Configure 69
Disable 69
Enable 69

TALC System Configuration
Beep Tone Level 61
Day 62
DN Discovery Schedule

Date 62
Start DN Discovery 62
TALC Extension to Dial 63

Enable DN Discovery 61
Frequency 62
General Config

Engage Record Feature 61
Engage Record Server IP Address 61
Node Name 61
Per DN Recording 61
Unit ID 61

Time 62
TAPI Support 72
Time 62

U
Unit ID 61



TelStrat Application Line Card Installation and Administration Guide 115

Index

Numerics
25-pair connector 17

A
ACD

DN Discovery 56
PBX class-of-service 57

adding TelStrat DSP 8 modules 15
add-on modules

compatibility 10
administration

changing the administration password 75
creating a backup configuration file 78
restoring the configuration 80

administration password
see passwords

B
backup

creating a backup configuration file 78
introduction 78
storing 78
when to create 78

C
cabling

cabling the TALC 17
NT8D81AA 2
P1, P2, P3, P4, P5, P6 connectors 9
TALC Multi-I/O cable-Enhanced

cable diagram 9
verification 18

card slot
configuring 55

CAT5 data cable 27
catastrophic failure 106
CD

Engage Record CD-ROM v

clearing logs 85
Common Features Specification 3
Communication Server 1000 (CS 1000) v
Communication Server 2100 (CS 2100) v
compatibility

modules 10
configuration

card slot 55
initial 19
minimum 20
PBX 55
TALC 55–71
TALC IP 64–67
TALC port 68–71
TALC system 55–64
Wizard 20

configuration file
creating a backup file 78
storing 78

Configuration Manager
closing 53
command buttons 34
configuration

downloading 42
uploading 42

configuration file
creating 41
opening 42

File Operations
Diagram 35

file operations
description 37

logging off of a TALC 50
logging on to a TALC 43
password

changing 75
overview 75

software
installation 18

software problems
troubleshooting 102

symptom descriptions 102
system tree 33



116 TelStrat Application Line Card Installation and Administration Guide

Index Standard 3.6

Configuration Wizard 20
introduction 19
performing a configuration 20
starting 19
using to perform initial configuration 19
what you can configure 19

configuring the TALC
IP addresses 64

connection
checking host-site connections 27
unsuccessful ping 28

connection history 44
connectivity

troubleshooting 98
PING

failure 105
symptom descriptions 98

CS 1000 2
CS 2100 2

D
data ports

configure as MCA adapters 4
DB-15 connector 27
DB-9 connector 17
device connectivity 98
displaying logs 83
DN Discovery

ACD environments 56
PBX class-of-service 57

PBX class-of-service 57
Tandem Digit Display 4

DN discovery
explained 56
how it works 56

Download Configuration 40
DSP 7, 15, 86

handling modules 15
DSP Statistics screen 86

E
Engage Record CD-ROM v
Engage Record software v
Enhanced cable

plugs 108
environmental conditions 12
Environmental Requirements 12

TALC 12
equipment 10
Ethernet

checking the connection 27
extended digital line card (XDLC) 1, 11, 16, 55

F
faceplates 6
failure to operate 106
Feature key 63
File Open 37
File Operations

Diagram 35
File Save As 37
firmware

performing an upgrade 92
TALC v
upgrade 102, 103
verifying firmware version 90

fixed seating 69
free seating 69

H
handling TelStrat DSP 8 modules 15
hardware compatibility

PBX 1
hardware installation tools 13

I
identifying why a problem occurred 95
initial TALC configuration 19
inoperative equipment 106
input/output port (IOP) 17
installing TelStrat DSP 8 modules 15

determining how many to add 15
handling TelStrat DSP 8 modules 15
introduction 15
to install TelStrat DSP 8 modules 16

installing the TALC
cabling the TALC 17
general safety 13
indications of proper cabling 18
indications of proper installation 17
installing TelStrat DSP 8 modules 15
installing the Configuration Manager software 
18
required tools 13
testing the connection 27
unable to log on 18
using Configuration Wizard 19
verifying the installation 17

Internet Protocol (IP)
address 19
default gateway 19
entering the IP address 66
IP addresses 64
subnet mask 19
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IP addresses
 see Internet Protocol (IP)

IPE
modules 2
shelves 3

NT8D37AA 2

L
LD 11 4
LEDs

LED indicators 7
self test 17

line card
firmware upgrade 102, 103
installation

verification 18
password 75

changing 76
XDLC (extended digital line card) 1, 11, 16, 55

logging off of a TALC 50
logging on to a TALC

connection history 44
connection types 43
from Configuration Manager 43
through serial port 48
through Telnet 46

logon ID
Configuration Manager 75
TALC 75

logs
clearing 85
displaying 83
resizing 84

M
MCA adapters 4
Meridian 1 PBX v

hardware 1
software

Release 15 3
Release 17 3
Release 18 and above 4

Meridian 1 PBX 11C - Cabinet 1
Meridian 1 PBX 11C - Chassis 1
Meridian 1 PBX 11E 1
Meridian 1 PBX 51C 1
Meridian 1 PBX 61C 1
Meridian 1 PBX 71C 1
modules

compatibility 10

N
network ports

configuration 4
NT8D37AA 2
NT8D81AA 2

O
OK 37
Operational Characteristics 11

P
packet voice 11

voice compression 11
password

administration
changing 75

passwords
changing 76
Configuration Manager 75
TALC 75

PBX
configuration 55
hardware and software compatibility

hardware 1
Meridian 1 PBX 11C - Cabinet, Meridian 
1 PBX 11C - Chassis, Meridian 1 PBX 
11E, Meridian 1 PBX 21E, Meridian 1 
PBX 51C, Meridian 1 PBX 61C, Meridi-
an 1 PBX 71C, Meridian 1 PBX 81C 1

software 3
Release 15 3
Release 17 3
Release 18 and above 4

PBX Terminology v
Host PBX v

CS 1000 v
CS 2100 v
Meridian 1 PBX v

PBXs
Communication Server 1000 (CS 1000) 2
Communication Server 2100 (CS 2100) 2
Meridian 1 PBX 11C - Cabinet 1
Meridian 1 PBX 11C - Chassis 1
Meridian 1 PBX 11E 1
Meridian 1 PBX 21E 1
Meridian 1 PBX 51C 1
Meridian 1 PBX 61C 1
Meridian 1 PBX 71C 1
Meridian 1 PBX 81C 1

performing initial configuration 19
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physical features
faceplate diagrams 6
introduction 1
IPE vs Meridian 1 PBX 11 3
LED indicators 7
TelStrat DSP 8 modules 7

PING 104
failure 105
unsuccessful ping 28

pin-out
TALC Multi-I/O cable—Enhanced 109

pin-out tables
TALC Multi I/O cable—Enhanced 107

ports
configuring on TALC 70
fixed seating 69
free seating 69
network port configuration 4

problems
solving

catastrophic failure 106
connectivity 98

PING failure 105
symptom descriptions 98

LEDs as indicators 96
PING procedure 104
software problems 102

symptom descriptions 102
Publications

Related
obtaining vi

R
Related Product Information

How to Obtain the Engage Record CD-
ROM and Publications vi

Engage Record CD-ROM v
Related Publications

obtaining vi
resizing logs 84
restarting the system

when to perform a restart 51
restore

before you begin 80
uploading a configuration file over the IP 
network 80

Retrieve 38
RJ-45 connector 17, 27

S
safety during installation 13

Save to Flash 39
seating

fixed 69
free 69

Send 38
Send All 38
serial port

logging on to a TALC 48
shutting down the system

performing a system shutdown 52
software

compatibility
PBX 3

Release 15 3
Release 17 3
Release 18 and above 4

Engage Record v
installation or upgrade tools 13
problems 102
TALC Configuration Manager v
upgrades 94

performing 94
verifying the software version 90

split-slot wiring 2
statistics

DSP Statistics screen 86
VCT Statistics screen 88

system tree 33

T
TALC

changing the administration password 75
configuring

refer to configuration
Environmental Requirements 12
faceplates diagram 6
firmware

upgrade 102, 103
hardware compatibility

PBX 1
installation

verification 18
LEDs

troubleshooting 96
Operational Characteristics 11
packet voice 11
password

changing 76
overview 75

PBX Software Compatibility 3
physical features 1

TALC Configuration Manager v
software v
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TALC firmware v
TALC Multi-I/O cable—Enhanced 8, 9, 108–109

pin-out
table 107

pin-out tables 109
plugs 108

Tandem Digit Display 4
TDD 4
telephone hardware

compatibility
add-on modules 10

Telnet
using to log on to a TALC 46

TelStrat Application Line Card
refer to TALC 1

TelStrat DSP 8 modules
determining how many to add 15
DSP Statistics screen 86
handling 15
installation 15
overview 7
see installing TelStrat DSP 8 modules 15

TFTP
refer to Trivial File Transfer Protocol (TFTP)

tools
hardware installation tools 13
introduction 13
software installation or upgrade tools 13

Trivial File Transfer Protocol (TFTP) 80, 92
TALC firmware upgrade 102, 103

troubleshooting
before you begin 95
catastrophic failure 106
connectivity 98

PING failure 105
symptom descriptions 98

device connectivity 98
LEDs as indicators 96
PING procedure 104
software problems 102

symptom descriptions 102

U
upgrades

performing
obtaining the latest upgrade file 92
performing a firmware upgrade 92
performing a software upgrade 94
verifying the firmware and software version 
90
when to perform a firmware upgrade 92

upgrades, performing
upgrades and configuration files 92

Upload Configuration 40
using Configuration Manager PING 104

V
VCT Statistics screen 88
voice compression 11

W
wiring

special requirements 2

X
XDLC 11, 55

refer to extended digital line card (XDLC)
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